1106. Lowest Price in Supply Chain

1106. Lowest Price in Supply Chain (25)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N-1, and the root supplier's ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

Ki ID[1] ID[2] ... ID[Ki]

where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. Kj being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 1010.

Sample Input:
10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0
2 6 1
1 8
0
0
0
Sample Output:
1.8362 2
输入之后bfs,到首次零售商出现的那一层,记下层数maxl和零售商数maxn,之后计算价格输出。
#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>

const int INF=0x7fffffff;
using namespace std;

typedef struct node
{
	vector<int>c;
	int l;
	bool f;
};
node p[100000];
int main()
{
	int n;
	double price,rate;
	cin>>n>>price>>rate;
	for(int i=0;i<n;++i)
	{
		int num;
		cin>>num;
		p[i].f=false;
		for(int j=0;j<num;++j)
		{
			int c;
			cin>>c;
			p[i].c.push_back(c);
		}
	}
	queue<int> q;
	p[0].f=true;
	p[0].l=0;
	q.push(0);
	int r;
	int pn=1;
	int maxl=0,maxn=0;
	while(!q.empty())
	{
		int tmp;
		for(int i=0;i<pn;++i)
		{
			tmp=q.front();
			q.pop();
			if(p[tmp].c.empty())
			{
				maxl=p[tmp].l;
				maxn++;
			}
			else
			{
				for(int j=0;j<p[tmp].c.size();++j)
				{
					if(p[p[tmp].c[j]].f)
						continue;
					p[p[tmp].c[j]].l=p[tmp].l+1;
					p[p[tmp].c[j]].f=true;
					q.push(p[tmp].c[j]);
				}
			}
		}
		if(maxn)
			break;
		pn=q.size();
	}
	while(maxl--)
		price*=(1+rate/100);
	printf("%.4lf %d",price,maxn);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值