1069. The Black Hole of Numbers

1069. The Black Hole of Numbers (20)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the "black hole" of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0, 10000).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation "N - N = 0000". Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:
6767
Sample Output 1:
7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
Sample Input 2:
2222
Sample Output 2:
2222 - 2222 = 0000
之前写过这个题,看了一下,还可以,就不改了,按流程来即可。
#include<iostream>
#include<string>
#include<algorithm>
#include<iomanip>

using namespace std;

int main()
{
	int n,s=0;
	int a[4],b[4]={0,0,0,0};
	cin>>n;
	while(s!=6174)
	{
		for(int i=0;i<4;i++)
		{
			a[i]=n%10;
			n=n/10;
		}
		if(a[0]==a[1]&&a[0]==a[2]&&a[0]==a[3])
		{
			cout<<a[0]<<a[1]<<a[2]<<a[3]<<" - ";
			cout<<a[0]<<a[1]<<a[2]<<a[3]<<" = 0000"<<endl;
			break;
		}
		sort(a,a+4);
		for(int i=0;i<4;i++)
			b[i]=a[3-i];
		int a1=0,b1=0;
		for(int i=0;i<4;i++)
		{
			a1=a1*10+a[i];
			b1=b1*10+b[i];
		}
		s=b1-a1;
		n=s;
		cout<<setfill('0')<<setw(4)<<b1<<" - "
			<<setfill('0')<<setw(4)<<a1<<" = "
			<<setfill('0')<<setw(4)<<s<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值