HDU 1036 Average is not Fast Enough!


Problem Description
A relay is a race for two or more teams of runners. Each member of a team runs one section of the race. Your task is to help to evaluate the results of a relay race.

You have to process several teams. For each team you are given a list with the running times for every section of the race. You are to compute the average time per kilometer over the whole distance. That's easy, isn't it?
So if you like the fun and challenge competing at this contest, perhaps you like a relay race, too. Students from Ulm participated e.g. at the "SOLA" relay in Zurich, Switzerland. For more information visit http://www.sola.asvz.ethz.ch/ after the contest is over.
 

Input
The first line of the input specifies the number of sections n followed by the total distance of the relay d in kilometers. You may safely assume that 1 <= n <= 20 and 0.0 < d < 200.0. Every following line gives information about one team: the team number t (an integer, right-justified in a field of width 3) is followed by the n results for each section, separated by a single space. These running times are given in the format "h:mm:ss" with integer numbers for the hours, minutes and seconds, respectively. In the special case of a runner being disqualified, the running time will be denoted by "-:--:--". Finally, the data on every line is terminated by a newline character. Input is terminated by EOF.
 

Output
For each team output exactly one line giving the team's number t right aligned in a field of width 3, and the average time for this team rounded to whole seconds in the format "m:ss". If at least one of the team's runners has been disqualified, output "-" instead. Adhere to the sample output for the exact format of presentation.
 

Sample Input
  
  
2 12.5 5 0:23:21 0:25:01 42 0:23:32 -:--:-- 7 0:33:20 0:41:35
 

Sample Output
  
  
5: 3:52 min/km 42: - 7: 6:00 min/km
 

Source
 
 
其实就是一个水题。
格式挺麻烦。
上个代码自然都懂了
 
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#include<iostream>
int main()
{
	double n;
	double l;
	scanf("%lf%lf",&n,&l);
	int i;
	int p;
	while(scanf("%d",&p)!=EOF)
	{
		char s[32][323];
		double sum=0;
		int flag=0;
		for(i=1;i<=n;i++)
		{
			scanf("%s",s[i]);
			if(s[i][0]=='-')
				flag=1;	
		}
		if(flag)
		{
			printf("%3d: -\n",p);
			continue;
		}
		printf("%3d:",p);
		for(i=1;i<=n;i++)
			sum+=(s[i][0]-'0')*3600+((s[i][2]-'0')*10+(s[i][3]-'0'))*60+(s[i][5]-'0')*10+(s[i][6]-'0');
		int x=sum/l;
		if(sum/l-x>0.5)
			x++;
		printf(" %d:%02d min/km\n",x/60,x%60);
	}
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值