Pots

这道题需要用到广搜对那三种(其实是六种操作)进行判断,最后用递归输出

You are given two pots, having the volume of A and B liters respectively. The following operations can be performed:

  1. FILL(i)        fill the pot i (1 ≤ ≤ 2) from the tap;
  2. DROP(i)      empty the pot i to the drain;
  3. POUR(i,j)    pour from pot i to pot j; after this operation either the pot j is full (and there may be some water left in the pot i), or the pot i is empty (and all its contents have been moved to the pot j).

Write a program to find the shortest possible sequence of these operations that will yield exactly C liters of water in one of the pots.

Input

On the first and only line are the numbers AB, and C. These are all integers in the range from 1 to 100 and C≤max(A,B).

Output

The first line of the output must contain the length of the sequence of operations K. The following K lines must each describe one operation. If there are several sequences of minimal length, output any one of them. If the desired result can’t be achieved, the first and only line of the file must contain the word ‘impossible’.

Sample Input
3 5 4
Sample Output
6
FILL(2)
POUR(2,1)
DROP(1)
POUR(2,1)
FILL(2)
POUR(2,1)

#include<stdio.h>
#include<queue>
#include<stack>
using namespace std;
struct list
{
	int a_volume;
	int b_volume;
	int prea_volume;
	int preb_volume;
	int step;
	int op;
};
queue<struct list> q;
stack<struct list> s;
void show(int a,int b);
bool book[105][105];
int main()
{
	int a,b,c;
	struct list n;	
	scanf("%d%d%d",&a,&b,&c);
	n.a_volume=0;
	n.b_volume=0;
	n.prea_volume=-1;
	n.preb_volume=-1;
	n.step=0;
	n.op=-1;
	book[0][0]=true;	
	q.push(n);
	while(!q.empty()&&!(q.front().a_volume==c||q.front().b_volume==c))
	{
		n.a_volume=a;                   //fill a
		n.b_volume=q.front().b_volume;        
		if(book[n.a_volume][n.b_volume]==false)
		{
			book[n.a_volume][n.b_volume]=true;
			n.prea_volume=q.front().a_volume;
			n.preb_volume=q.front().b_volume;
			n.step=q.front().step+1;
			n.op=1;
			q.push(n);
		}
		n.b_volume=b;                     //fill b
		n.a_volume=q.front().a_volume;           
		if(book[n.a_volume][n.b_volume]==false)
		{
			book[n.a_volume][n.b_volume]=true;
			n.prea_volume=q.front().a_volume;
			n.preb_volume=q.front().b_volume;
			n.step=q.front().step+1;
			n.op=2;
			q.push(n);
		}
		n.a_volume=0;                  //drop a
		n.b_volume=q.front().b_volume;              
		if(book[n.a_volume][n.b_volume]==false)
		{
			book[n.a_volume][n.b_volume]=true;
			n.prea_volume=q.front().a_volume;
			n.preb_volume=q.front().b_volume;
			n.step=q.front().step+1;
			n.op=3;
			q.push(n);
		}
		n.b_volume=0;             //drop b
		n.a_volume=q.front().a_volume; 
		if(book[n.a_volume][n.b_volume]==false)
		{
			book[n.a_volume][n.b_volume]=true;
			n.prea_volume=q.front().a_volume;
			n.preb_volume=q.front().b_volume;
			n.step=q.front().step+1;
			n.op=4;
			q.push(n);
		}
		if(q.front().a_volume+q.front().b_volume>b)    //pour a b
		{
			n.a_volume=q.front().a_volume-(b-q.front().b_volume);
			n.b_volume=b;
		}
		else
		{
			n.a_volume=0;
			n.b_volume=q.front().b_volume+q.front().a_volume;
		}	            
		if(book[n.a_volume][n.b_volume]==false)
		{
			book[n.a_volume][n.b_volume]=true;
			n.prea_volume=q.front().a_volume;
			n.preb_volume=q.front().b_volume;
			n.step=q.front().step+1;
			n.op=5;
			q.push(n);
		}
		if(q.front().a_volume+q.front().b_volume>a)    //pour b a
		{
			n.a_volume=a;
			n.b_volume=q.front().b_volume-(a-q.front().a_volume);
		}
		else
		{
			n.a_volume=q.front().b_volume+q.front().a_volume;
			n.b_volume=0;
		}	            
		if(book[n.a_volume][n.b_volume]==false)
		{
			book[n.a_volume][n.b_volume]=true;
			n.prea_volume=q.front().a_volume;
			n.preb_volume=q.front().b_volume;
			n.step=q.front().step+1;
			n.op=6;
			q.push(n);
		}
		s.push(q.front());
		q.pop();
	}
	if(q.empty())
		printf("impossible");
	else
	{
		s.push(q.front());
		printf("%d\n",q.front().step);
		show(q.front().a_volume,q.front().b_volume);
	}		
	return 0;
} 
void show(int a,int b)
{
	if(a==0&&b==0)
		return ;
	while(s.top().a_volume!=a||s.top().b_volume!=b)
		s.pop();
	int prea,preb,operation;
	prea=s.top().prea_volume;
	preb=s.top().preb_volume;
	operation=s.top().op;
	show(prea,preb);
	if(operation==1)
		printf("FILL(1)\n");
	else if(operation==2)
		printf("FILL(2)\n");
	else if(operation==3)
		printf("DROP(1)\n");
	else if(operation==4)
		printf("DROP(2)\n");
	else if(operation==5)
		printf("POUR(1,2)\n");
	else if(operation==6)
		printf("POUR(2,1)\n");
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值