hdu2923 floyd基础

Einbahnstrasse

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1604    Accepted Submission(s): 442


Problem Description
Einbahnstra   e (German for a one-way street) is a street on which vehicles should only move in one direction. One reason for having one-way streets is to facilitate a smoother flow of traffic through crowded areas. This is useful in city centers, especially old cities like Cairo and Damascus. Careful planning guarantees that you can get to any location starting from any point. Nevertheless, drivers must carefully plan their route in order to avoid prolonging their trip due to one-way streets. Experienced drivers know that there are multiple paths to travel between any two locations. Not only that, there might be multiple roads between the same two locations. Knowing the shortest way between any two locations is a must! This is even more important when driving vehicles that are hard to maneuver (garbage trucks, towing trucks, etc.)

You just started a new job at a car-towing company. The company has a number of towing trucks parked at the company's garage. A tow-truck lifts the front or back wheels of a broken car in order to pull it straight back to the company's garage. You receive calls from various parts of the city about broken cars that need to be towed. The cars have to be towed in the same order as you receive the calls. Your job is to advise the tow-truck drivers regarding the shortest way in order to collect all broken cars back in to the company's garage. At the end of the day, you have to report to the management the total distance traveled by the trucks.
 

Input
Your program will be tested on one or more test cases. The first line of each test case specifies three numbers (N , C , and R ) separated by one or more spaces. The city has N locations with distinct names, including the company's garage. C is the number of broken cars. R is the number of roads in the city. Note that 0 < N < 100 , 0<=C < 1000 , and R < 10000 . The second line is made of C + 1 words, the first being the location of the company's garage, and the rest being the locations of the broken cars. A location is a word made of 10 letters or less. Letter case is significant. After the second line, there will be exactly R lines, each describing a road. A road is described using one of these three formats:


A -v -> B
A <-v - B
A <-v -> B


A and B are names of two different locations, while v is a positive integer (not exceeding 1000) denoting the length of the road. The first format specifies a one-way street from location A to B , the second specifies a one-way street from B to A , while the last specifies a two-way street between them. A , ``the arrow", and B are separated by one or more spaces. The end of the test cases is specified with a line having three zeros (for N , C , and R .)

The test case in the example below is the same as the one in the figure. 

 

Output
For each test case, print the total distance traveled using the following format:


k . V


Where k is test case number (starting at 1,) is a space, and V is the result.
 

Sample Input
  
  
4 2 5 NewTroy Midvale Metrodale NewTroy <-20-> Midvale Midvale --50-> Bakerline NewTroy <-5-- Bakerline Metrodale <-30-> NewTroy Metrodale --5-> Bakerline 0 0 0
 

Sample Output
  
  
1. 80
 

Source
最痛苦的就是卡在水题上 反复检查n久 终于AC了。。。

代码
#include <iostream>
#include <cstdio>
#include <cstring>
#include<stdlib.h>
using namespace std;
#define INF 99999999
int map[111][111];
char name [111][22];
int top;
void floyd(int n)
{
    for (int k=0;k<n;++k)
    {
        for (int i=0;i<n;++i)
        {
            for (int j=0;j<n;++j)
            {
                if (map[i][k]!=INF && map[k][j]!=INF &&map[i][k]+map[k][j]<map[i][j])
                {
                    map[i][j]=map[i][k]+map[k][j];
                }
            }
        }
    }
}
int find(char s[])
{
    for(int i=0;i<top;i++)
    {
        if(!strcmp(s,name[i]))
           return i;
    }
    strcpy(name[top++],s);
    return top-1;
}
void init()
{
    int i,j;
    for(i=0;i<111;i++ )
    {
        for(j=0;j<111;j++ )
        {
            map[i][j]=INF;
        }
    }
}
int sqr(int i)
{
    int a=1;
    while(i--)a*=10;
    return a;
}
int getn(char a[])
{
    int i;
    int sum=0;
    int l=strlen(a);
    for(i=l-3;i>1;i--)
    {
        sum+=((a[i]-'0')*sqr(l-3-i));
    }
    return sum;
}
int main()
{
    int N,C,R;
    char car[1111][22];
    char s1[22],s2[22],s3[22];
    int v;
    int cas=1;
    while(scanf("%d%d%d",&N,&C,&R))
    {memset(name,0,sizeof(name));
        if(!(N+C+R))
            break;
        cin>>name[0];
       for(int i=0;i<C;i++)
        cin>>car[i];
        top=1;
        init();
        for(int i=0; i<R; i++)
        {
            getchar();
            scanf("%s%s%s",s1,s2,s3);
            v=getn(s2);
            int a1=find(s1);
            int a2=find(s3);
            if(s2[0]=='<'&&map[a2][a1]>v)
                map[a2][a1]=v;
            if(s2[strlen(s2)-1]=='>'&&map[a1][a2]>v)
                map[a1][a2]=v;
        }
    floyd(N);
    int ans=0;
    map[0][0]=0;
    for(int i=0;i<C;i++)
    {
        int t=find(car[i]);
        ans+=(map[0][t]+map[t][0]);
    }
     cout<<cas++<<". "<<ans<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值