【HDU6154 2017中国大学生程序设计竞赛 - 网络选拔赛 E】【贪心 构造】CaoHaha's staff 方格纸画面积最小笔画数

84 篇文章 5 订阅
24 篇文章 0 订阅

CaoHaha's staff

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 329    Accepted Submission(s): 191


Problem Description
"You shall not pass!"
After shouted out that,the Force Staff appered in CaoHaha's hand.
As we all know,the Force Staff is a staff with infinity power.If you can use it skillful,it may help you to do whatever you want.
But now,his new owner,CaoHaha,is a sorcerers apprentice.He can only use that staff to send things to other place.
Today,Dreamwyy come to CaoHaha.Requesting him send a toy to his new girl friend.It was so far that Dreamwyy can only resort to CaoHaha.
The first step to send something is draw a Magic array on a Magic place.The magic place looks like a coordinate system,and each time you can draw a segments either on cell sides or on cell diagonals.In additional,you need 1 minutes to draw a segments.
If you want to send something ,you need to draw a Magic array which is not smaller than the that.You can make it any deformation,so what really matters is the size of the object.
CaoHaha want to help dreamwyy but his time is valuable(to learn to be just like you),so he want to draw least segments.However,because of his bad math,he needs your help.
 

Input
The first line contains one integer T(T<=300).The number of toys.
Then T lines each contains one intetger S.The size of the toy(N<=1e9).
 

Output
Out put T integer in each line ,the least time CaoHaha can send the toy.
 

Sample Input
  
  
5 1 2 3 4 5
 

Sample Output
  
  
4 4 6 6 7
 

Source
 

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<string>
#include<ctype.h>
#include<math.h>
#include<set>
#include<map>
#include<vector>
#include<queue>
#include<bitset>
#include<algorithm>
#include<time.h>
using namespace std;
void fre() { freopen("c://test//input.in", "r", stdin); freopen("c://test//output.out", "w", stdout); }
#define MS(x, y) memset(x, y, sizeof(x))
#define ls o<<1
#define rs o<<1|1
typedef long long LL;
typedef unsigned long long UL;
typedef unsigned int UI;
template <class T1, class T2>inline void gmax(T1 &a, T2 b) { if (b > a)a = b; }
template <class T1, class T2>inline void gmin(T1 &a, T2 b) { if (b < a)a = b; }
const int N = 1e5 + 10, M = 0, Z = 1e9 + 7, inf = 0x3f3f3f3f;
template <class T1, class T2>inline void gadd(T1 &a, T2 b) { a = (a + b) % Z; }
int casenum, casei;
LL f[N];
int main()
{
	f[4] = 4;
	f[5] = 5;
	for (int i = 6; i <= 1e5; ++i)
	{
		if (i & 1)
		{
			int L = (i - 1) / 2;
			LL a = L / 2;
			LL b = L - a;
			f[i] = a * b * 4 + (b * 2 - 1);
		}
		else
		{
			int L = i / 2;
			LL a = L / 2;
			LL b = L - a;
			f[i] = a * b * 4;
		}
	}
	scanf("%d", &casenum);
	for (casei = 1; casei <= casenum; ++casei)
	{
		int n;
		scanf("%d", &n); n *= 2;
		int p = lower_bound(f, f + 100001, n) - f;
		printf("%d\n", p);
	}
	return 0;
}
/*
【trick&&吐槽】
没有好好思考奇数长度要如何作图,导致了罚时与时间的浪费。

【题意】
在方格纸上,我们每笔可以沿着"横、竖、对角线"某条线画一笔
问你,如果要画使得面积 >= n,至少要画几笔?

【分析】
先在纸上瞎画一下。
贪心原理,显然尽可能使用sqrt(2)的边长。
对于偶数长度的笔画,我们可以画一个矩形,而使得其长与宽越接近答案越好。
对于奇数长度的笔画,我们可以使得较长的那条边向外突出一点。

画一画就觉得很对啦!

*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值