poj 2386 Lake Counting 深搜DFS

深搜的基础题。

题意如下:

                                                                                               Lake Counting

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3
代码如下:

#include<iostream>
 using namespace std;
 char map[110][110];
 int vis[110][110];

 void dfs(int x,int y)
 {
	 if(vis[x][y]==1 || map[x][y]=='.' || map[x][y]==0) return; //若为被访问的+是空地的+出界的, 则返回!
	 vis[x][y]=1;
	 dfs(x+1,y);    dfs(x+1,y+1);  dfs(x+1,y-1);  //对八个方向进行深搜
	 dfs(x,y+1);                   dfs(x,y-1);
	 dfs(x-1,y-1);  dfs(x-1,y);    dfs(x-1,y+1);
 }
 int main()
 {
	 memset(map,0,sizeof(map));            //初始化为0,以后作为边界。
	 memset(vis,0,sizeof(vis));            //没有访问的被初始化为0.
	 int m,n,cnt=0;
	 int i,j;
	 cin>>m>>n;
	 for(i=1;i<=m;++i)
		 for( j=1;j<=n;++j)
			 cin>>map[i][j];             //数据放在中间,周围是0,好判断是否出界。

		 for( i=1; i<=m;++i)
			 for(  j=1;j<=n;++j)
			 {
				 if(!vis[i][j] && map[i][j]=='W')
				 {
					 ++cnt;
					 dfs(i,j);
				 }
			 }
				 cout<<cnt<<endl;
				 return 0;
 }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值