zju 1002 zoj 1002

Fire Net

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Suppose that we have a square city with straight streets. A map of a city is a squareboard with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand,a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city aspossible so that no two can destroy each other. A configuration ofblockhouses islegal provided that no two blockhouses are on the samehorizontal row or vertical column in a map unless there is at least one wallseparating them. In this problem we will consider small square cities (at most 4x4) that contain walls through whichbullets cannot run through.

The following image shows five pictures of the same board. Thefirst picture is the empty board, the second and third pictures show legalconfigurations, and the fourth and fifth pictures show illegal configurations.For this board, the maximum number of blockhouses in a legal configurationis 5; the second picture shows one way to do it, but there are severalother ways.

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in thecity in a legal configuration.

The input file contains one or more map descriptions, followed bya line containing the number 0 that signals the end of the file. Eachmap description begins with a line containing a positive integernthat is the size of the city;n will be at most 4. The next nlines each describe one row of the map, with a '.' indicating anopen space and an uppercase 'X' indicating a wall. There are nospaces in the input file.

For each test case, output one line containing themaximum number of blockhouses that can be placed in the cityin a legal configuration.

Sample input:

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample output:

5
1
5
2
4

回溯法做的,不过我听说好像用贪心也可以AC,有兴趣的可以试试

#include<stdio.h>
char maze[4][4];
int most,now,n;

int backtrack(int x,int y){
    if(x==n){
        if(now>most){
            most=now;
        }
        return 0;
    }
    int i,flag=0;
    if(maze[x][y]=='.'){
        for(i=x;i<n;i++){
            if(maze[i][y]=='X') break;
            if(maze[i][y]=='#') flag=1;
        }
        for(i=x;i>=0;i--){
            if(maze[i][y]=='X') break;
            if(maze[i][y]=='#') flag=1;
        }
        for(i=y;i<n;i++){
            if(maze[x][i]=='X') break;
            if(maze[x][i]=='#') flag=1;
        }
        for(i=y;i>=0;i--){
            if(maze[x][i]=='X') break;
            if(maze[x][i]=='#') flag=1;
        }
        if(!flag){
            maze[x][y]='#';
            now++;
            if(y+1>=n) backtrack(x+1,0);
            else backtrack(x,y+1);
            now--;
            maze[x][y]='.';
        }
    }
    if(y+1>=n) backtrack(x+1,0);
    else backtrack(x,y+1);
}

int main(){
    int i;
    while(scanf("%d",&n),n){
        most=0,now=0;
        for(i=0;i<n;i++){
            scanf("%s",maze[i]);
        }
        backtrack(0,0);
        printf("%d\n",most);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值