关闭

Unsupported major.minor version 51.0 错误处理

标签: tomcat服务器jdk版本
595人阅读 评论(0) 收藏 举报
分类:

今天在发布系统新版本后,启动服务器(包括tomcat跟weblogic)就莫名其妙的报了Unsupported major.minor version 51.0这个错,其中启动tomcat时总是一闪而过,编辑startup.bat,在文本的最后加上pause后也看不到错误信息,在日志文件中或者weblogic中可以看到此处报了Unsupported major.minor version 51.0的错误,其中后面还会跟着load不了的类名称。经过一番摸索后发现问题出现在了jdk的版本上,因为自己在弄android的时候换了intellij idea,无意间把本地的jdk换成了1.7版本,而部署项目的服务器安装的是1.6版本的jdk,自己本地用1.7版本编译后发布在服务器上就出现了这个问题。

处理方法:根据服务器jdk的版本,本地用跟其一样的版本重新编译发布即可。

ps:有时候不同版本编译多后启动tomcat会报一些错,只需要把tomcat文件夹中work\Catalina\localhost里的文件删了之后重新启动即可解决。

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:19967次
    • 积分:348
    • 等级:
    • 排名:千里之外
    • 原创:14篇
    • 转载:6篇
    • 译文:0篇
    • 评论:1条
    文章分类
    最新评论