POJ 2002 Squares -- Hash

Squares
Time Limit: 3500MS Memory Limit: 65536K
Total Submissions: 15891 Accepted: 6016

Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property. 

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates. 

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input

4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output

1
6
1

Source


题意:给n(n<=1000)个点,计算其中所有点能够组成的不同正方形的个数,正方形位置或大小不同即为 不同。

做法:因为n<1000,所以枚举两个点,将其作为正方形的两个对角顶点,用数学知识算出来另两个对角顶点,判断另两个是否在点集里即可。判断的时候为了高效查找,可以用hash,将二维点映射成一维,便于判断,可以用邻接表存hash的结果。


具体见代码:

#include<iostream>
#include<algorithm>
using namespace std;
const int mod=1313131;
struct node{
	int x,y;
}p[1005];
struct edge{
	int u,v,next;
}e[mod];
int head[mod],ind;
void init()
{
	memset(head,-1,sizeof(head));
	ind = 0;
}
int My_hash(int x,int y)
{
	return (x*x+y*y)%mod;
}
void add(int x,int y)
{
	int key=My_hash(x,y);
	e[ind].u = x;
	e[ind].v = y;
	e[ind].next = head[key];
	head[key] = ind++;
}
bool Search(int x,int y)
{
	int key = My_hash(x,y);
	for (int i = head[key]; i !=-1 ; i=e[i].next)
	{
		if(e[i].u == x && e[i].v == y)
			return true;
	}
	return false;
}
int solve(int n)
{
	int ans = 0;
	for (int i = 0; i < n; i++)
	{
		for (int j = i+1; j < n; j++)
		{
	        int x1 = p[i].x - (p[i].y - p[j].y);  
                int y1 = p[i].y + (p[i].x - p[j].x);  
                int x2 = p[j].x - (p[i].y - p[j].y);  
                int y2 = p[j].y + (p[i].x - p[j].x);  
                if(Search(x1,y1) && Search(x2,y2)) ans++;  
		}
	}
	for(int i=0;i<n;i++)  
        {  
            for(int j=i+1;j<n;j++)  
            {  
            int x1 = p[i].x + (p[i].y - p[j].y);  
            int y1 = p[i].y - (p[i].x - p[j].x);  
            int x2 = p[j].x + (p[i].y - p[j].y);  
            int y2 = p[j].y - (p[i].x - p[j].x);  
            if(Search(x1,y1) && Search(x2,y2)) ans++;  
            }  
        }  
	ans /= 4;
	return ans;
}
int main()
{
	int n;
	while(cin>>n,n)
	{
		init();
		for (int i = 0; i < n; i++)
		{
			cin>>p[i].x>>p[i].y;
			add(p[i].x,p[i].y);
		}
		cout<<solve(n)<<endl;
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了安卓应用、小程序、Python应用和Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值