[ACM] hdu 4405 Aeroplane chess (概率DP)

286 篇文章 140 订阅
14 篇文章 0 订阅

Aeroplane chess



Problem Description
Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.
 

Input
There are multiple test cases. 
Each test case contains several lines.
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).  
The input end with N=0, M=0. 
 

Output
For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.
 

Sample Input
  
  
2 0 8 3 2 4 4 5 7 8 0 0
 

Sample Output
  
  
1.1667 2.3441
 

Source


解题思路:

题意为一条直线上有N+1个格子,编号0-N,也是其位置,有一枚骰子,比如当前位置你在i,骰子执到了 y点(1<=y<=6),那么下一步你就到了i+y位置,格子里有几个特殊的格子,可以从x位置瞬间转移到y位置,不需要步数,如果转移以后的格子还是特殊的格子,那么继续转移,要求的是,最后到达的位置>=n,所需要的投骰子次数的期望。

我们用 dp[i]表示当前位置到达位置>=n所需要投掷骰子的平均次数。

那么很明显有 dp[n]=0; 而我们要求的则是dp[0] (起点)

注意两点:

①不遇到特殊格子时,投掷一次筛子,由当前位置i到达位置 ,i+1 , i+2 , i+3 , i+4 , i+5 ,i+6 的概率是一样的,都是 1/6,那么 dp[i]=(dp[i+1] +dp[i+2]+....dp[i+6])/6 +1 (需要多投掷一次筛子,所以+1).

②遇到特殊格子时,当前位置的投掷骰子的平均次数等于转移到的位置的平均次数.  比如由x到y,  那么 dp[x]=dp[y];

根据以上两点,就可以写出代码.

dp[n]是已知的,需要从后往前推。

代码:

#include <iostream>
#include <iomanip>
#include <string.h>
using namespace std;
const int maxn=100005;
double dp[maxn];
int hash[maxn];
int n,m;

int main()
{
    while(cin>>n>>m&&(n||m))
    {
        int x,y;
        memset(hash,0,sizeof(hash));
        for(int i=1;i<=m;i++)
        {
            cin>>x>>y;
            hash[x]=y;//标记一下,x位置的格子是特殊格子
        }
        dp[n]=0;
        for(int i=n-1;i>=0;i--)
        {
            if(hash[i])//特殊格子
                dp[i]=dp[hash[i]];
            else
            {
                double temp=0;
                for(int j=1;j<=6&&i+j<=n;j++)
                    temp+=dp[i+j]/6;
                dp[i]=temp+1;
            }
        }
        cout<<setiosflags(ios::fixed)<<setprecision(4)<<dp[0]<<endl;

    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值