HDU1224 Free DIY Tour

Problem Description
Weiwei is a software engineer of ShiningSoft. He has just excellently fulfilled a software project with his fellow workers. His boss is so satisfied with their job that he decide to provide them a free tour around the world. It's a good chance to relax themselves. To most of them, it's the first time to go abroad so they decide to make a collective tour.

The tour company shows them a new kind of tour circuit - DIY circuit. Each circuit contains some cities which can be selected by tourists themselves. According to the company's statistic, each city has its own interesting point. For instance, Paris has its interesting point of 90, New York has its interesting point of 70, ect. Not any two cities in the world have straight flight so the tour company provide a map to tell its tourists whether they can got a straight flight between any two cities on the map. In order to fly back, the company has made it impossible to make a circle-flight on the half way, using the cities on the map. That is, they marked each city on the map with one number, a city with higher number has no straight flight to a city with lower number. 

Note: Weiwei always starts from Hangzhou(in this problem, we assume Hangzhou is always the first city and also the last city, so we mark Hangzhou both  1 and N+1), and its interesting point is always 0.

Now as the leader of the team, Weiwei wants to make a tour as interesting as possible. If you were Weiwei, how did you DIY it?
 

Input
The input will contain several cases. The first line is an integer T which suggests the number of cases. Then T cases follows.
Each case will begin with an integer N(2 ≤ N ≤ 100) which is the number of cities on the map.
Then N integers follows, representing the interesting point list of the cities.
And then it is an integer M followed by M pairs of integers [Ai, Bi] (1 ≤ i ≤ M). Each pair of [Ai, Bi] indicates that a straight flight is available from City Ai to City Bi.
 

Output
For each case, your task is to output the maximal summation of interesting points Weiwei and his fellow workers can get through optimal DIYing and the optimal circuit. The format is as the sample. You may assume that there is only one optimal circuit. 

Output a blank line between two cases.
 

Sample Input
  
  
2 3 0 70 90 4 1 2 1 3 2 4 3 4 3 0 90 70 4 1 2 1 3 2 4 3 4
 

Sample Output
  
  
CASE 1# points : 90 circuit : 1->3->1 CASE 2# points : 90 circuit : 1->2->1

#include <iostream>
using namespace std;

struct City
{
	int num;
	int pre;
	int interst;
}city[102];
int con[102][102];
int dp[105];
int N;

int main()
{
	freopen("C:\\in.txt","r",stdin);
	int T;
	int cnt=0;
	scanf("%d",&T);
	while(T--){
		
		scanf("%d",&N);
		memset(con,0,sizeof(con));
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=N;i++){
			scanf("%d",&city[i].interst);
			city[i].num=i;
			city[i].pre=i;
		}
		city[N+1].num=1;
		city[N+1].interst=0;
		city[N+1].pre=1;
		int M;
		scanf("%d",&M);
		for(int i=1;i<=M;i++){
			int a,b;
			scanf("%d %d",&a,&b);
			con[a][b]=1;
		}
		for(int i=2;i<=N+1;i++)
			for(int j=1;j<i;j++)
				if(con[j][i]){
					if(dp[i]<dp[j]+city[i].interst){
						dp[i]=dp[j]+city[i].interst;
						city[i].pre=j;
					}
				}
		printf("CASE %d#\npoints : %d\ncircuit : ",++cnt,dp[N+1]);

		int k=0;
		int ans[105];
		for(int i=N+1;i>1;i=city[i].pre)
			ans[k++]=city[i].pre;
		for(int i=k-1;i>=0;i--)
			printf("%d->",ans[i]);
		printf("1\n");
		if(T)printf("\n");
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值