Help Hanzo (素数筛+区间枚举)

 

 

Help Hanzo

Time Limit:2000MS     Memory Limit:32768KB    64bit IO Format:%lld & %llu

Description

Amakusa, the evil spiritual leader has captured the beautiful princess Nakururu. The reason behind this is he had a little problem with Hanzo Hattori, the best ninja and the love of Nakururu. After hearing the news Hanzo got extremely angry. But he is clever and smart, so, he kept himself cool and made a plan to face Amakusa.

Before reaching Amakusa's castle, Hanzo has to pass some territories. The territories are numbered asa, a+1, a+2, a+3 ... b. But not all the territories are safe for Hanzo because there can be other fighters waiting for him. Actually he is not afraid of them, but as he is facing Amakusa, he has to save his stamina as much as possible.

He calculated that the territories which are primes are safe for him. Now givena and b he needs to know how many territories are safe for him. But he is busy with other plans, so he hired you to solve this small problem!

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case contains a line containing two integers a and b (1 ≤ a ≤ b < 231, b - a ≤ 100000).

Output

For each case, print the case number and the number of safe territories.

Sample Input

3

2 36

3 73

3 11

Sample Output

Case 1: 11

Case 2: 20

Case 3: 4

Help Hanzo





题意:求a~b间素数个数(1 ≤ a ≤ b < 231, b - a ≤ 100000).     (全题在文末)

 

题解:My New Blog

a~b枚举必定TLE,普通打表MLE,真是头疼。。

b - a ≤ 100000 是关键。

类似素数筛的方法:

1.初始化vis[]=0 ;

2.素数的倍数vis[]=1;    

3.  b较小时,素数筛解决

   b很大时,素数筛的vis[]会MLE,此时用vis2[i-a]保存vis[i]就不会MLE 了。。

 

 

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
typedef long long LL;
const int N=1e6+5;

bool vis[N],visab[N];
int prime[N],cnt=0;
void is_prime()
{
    memset(vis,0,sizeof(vis));
    vis[1]=1;
    for(int i=2;i<N;i++)
    {
        if(!vis[i])
        {
            prime[cnt++]=i;
            for(int j=i+i;j<N;j+=i)
                vis[j]=1;
        }
    }
}


int main()
{
    int t;
    cin>>t;
    is_prime();
    for(int kase=1;kase<=t;kase++)
    {
        LL a,b;
        scanf("%lld%lld",&a,&b);
        int count=0;
        if(b<=N-1)
        {
            for(LL i=a;i<=b;i++)
            {
                if(!vis[i])
                    count++;
            }
        }
        else
        {
            memset(visab,0,sizeof(visab));
            for(int i=0;i<cnt&&prime[i]<=b;i++)
            {
                LL k=a/prime[i];
                if(k*prime[i]<a)
                    k++;
                for(LL j=k*prime[i];j<=b;j+=prime[i])
                {
                    visab[j-a]=1;
                }
            }
            for(LL i=a;i<=b;i++)
            {
                if(!visab[i-a])
                    count++;
            }
        }
        printf("Case %d: %d\n",kase,count);
    }
}

 


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 5
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 5
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值