pat 1053

1053. Path of Equal Weight (30)

时间限制
10 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard

Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.


Figure 1

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A1, A2, ..., An} is said to be greater than sequence {B1, B2, ..., Bm} if there exists 1 <= k < min{n, m} such that Ai = Bi for i=1, ... k, and Ak+1 > Bk+1.

Sample Input:
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19
Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2
 
 
//这个题用了一下午时间,第一次从根到叶子节点遍历的时候,是顺序遍历的,而不是按每次节点的最大值遍历。
//这样当找到后,没法排序。。。应该遍历时按每层的最大权值的顺序去遍历。
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int node[110][110], weight[110], path[110], ans[110][110], vis[110];
bool isYe[110];
int n, m, s, ams;

void calc(int root, int wgt, int num)
{
	int i, j;

	wgt += weight[root];

	if(wgt > s) return;

	path[num] = root;

	if(isYe[root] == true)
	{
		if(wgt == s)
		{
			for(i = 0; i <= num; i++)
				ans[ams][i] = weight[path[i]];
			ams++;
		}
		return;
	}

	for(j = 1; j <= n; j++)
	{
		int max = -1, index = -1;

		for(i = 1; i <= n; i++)
		{
			if(vis[i] == 0 && node[root][i] == 1)
			{
				if(weight[i] > max)  //找到权值最大的结点,不用再排序了。
				{
					max = weight[i];
					index = i;
				}
			}
		}

		if(index != -1)
		{
			vis[index] = 1;
			calc(index, wgt, num+1);
		}
	}
}

int main()
{
	int i, j, root, cnt, tmp;

	while(scanf("%d%d%d", &n, &m, &s) != EOF)
	{
		for(i = 0; i <= n; i++)
			isYe[i] = true;

		for(i = 0; i < n; i++)
			scanf("%d", &weight[i]);

		for(i = 0; i < m; i++)
		{
			scanf("%d%d", &root, &cnt);

			for(j = 0; j < cnt; j++)
			{
				scanf("%d", &tmp);
				node[root][tmp] = 1; //node[root][tmp] = 1表示tmp的双亲结点时root
				isYe[root] = false;
			}
		}

		memset(vis, 0, sizeof(vis));

		ams = 0;

		calc(0, 0, 0);

		for(i = 0; i < ams; i++)
		{
			printf("%d", ans[i][0]);
			j = 1;

			while(ans[i][j] != 0)
			{
				printf(" %d", ans[i][j]);
				j++;
			}

			printf("\n");
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值