nyoj103 A+B ProblemII

A+B Problem II

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 3
描述

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

A,B must be positive.

输入
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
输出
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation.
样例输入
2
1 2
112233445566778899 998877665544332211
样例输出
Case 1:
1 + 2 = 3
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110
 
    
#include<stdio.h>
#include<string.h>
int a[1010],b[1010];
char s1[1010],s2[1010];
void changenum(char *s,int *a)
{
	int start,end,i,t;
	start=0;end=strlen(s)-1;
	for(i=0;i<strlen(s);i++)
	{
		a[i]=s[i]-'0';
	}
	while(start<end)
	{
		t=a[start];
		a[start]=a[end];
		a[end]=t;
		start++;
		end--;
	}
}
int main()
{
	int T,j,i;
	scanf("%d",&T);
	for(j=1;j<=T;j++)
	{
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		scanf("%s%s",s1,s2);
		changenum(s1,a);
		changenum(s2,b);
		for(i=0;i<1010;i++)
		{
			a[i]=a[i]+b[i];
			if(a[i]>9)
			{
				a[i]=a[i]%10;
				a[i+1]++;
			}
		}
		for(i=1009;i>=0;i--)//去掉前缀0
		{
			if(a[i])
			break;
		}
		 printf("Case %d:\n%s + %s = " , j, s1, s2);
		if(i<0)
		printf("0\n");
		else
		for(;i>=0;i--)
		printf("%d",a[i]);
		printf("\n");
	}
	return 0;
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值