POJ 2299 Ultra-QuickSort

5 篇文章 0 订阅

Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 45088 Accepted: 16376

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,

Ultra-QuickSort produces the output
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

Source


归并排序,求逆序数。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>


using namespace std;
#define maxn 500005

long long n,cnt;
long long arr[maxn];
long long b[maxn];
void divide(int low, int high);
void mergeSort(int low,int mid,int high);
int main()
{
    while(scanf("%d",&n)!= EOF && n){
            cnt = 0;
        for(int i = 0 ; i < n;i++){
            scanf("%d",&arr[i]);
        }

        divide(0,n);
//        for(int i = 0; i < n ;i++){
//            cout << arr[i] << " ";
//        }
//        cout << endl << cnt << endl;
        cout << cnt << endl;
    }
    return 0;
}
void divide(int low, int high){

    if(high <= low +1){
        return ;
    }
    if(high == low + 2){
        if(arr[low] > arr[high - 1]){
            swap(arr[low],arr[high-1]);
            cnt ++;
        }
        return ;
    }
    if(low < high){
        int mid = (low + high) /2;
        divide(low,mid);
        divide(mid,high);
        mergeSort(low,mid,high);
    }

}
void mergeSort(int low,int mid,int high){

    int i = low, j = mid, k = low;
    while(i < mid || j < high){
         if(j >= high || ( i < mid && arr[i] <= arr[j])){
         	 b[k++] = arr[i++];
         }
         else
         {
             if(i < mid) cnt += (mid-i);
             b[k++] = arr[j++];
         }

    }

    for(i = low;i < high;i++){
        arr[i]=b[i];
    }

}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值