解决eclipse的new server里tomcat 无法选择问题

原创 2016年08月31日 09:24:19

最近由于某原因,又建立了一个新的workspace-new,切换回原来的workspace-old后,发现workspace-old中的项目无法在 tomcat v7.0 server正常工作了,于是各种设置均无法解决,最终一不做二不休删除了tomcat server。删除后,重新new server,然而新问题又出现了,无法选择tomcat v7.0 server 、tomcat v8.0 server,记得以前遇到过这个问题,但是记不起来当时怎么设置的,于是求助万能的百度,还是自己记下来的好,省的下次再忘记了,步骤如下:

一、退出eclipse;

二、找到自己的workspace,也就是我的workspace-old\.metadata\.plugins\org.eclipse.core.runtime\.settings这个路径, 删除文件org.eclipse.wst.server.core.prefs和org.eclipse.jst.server.tomcat.core.prefs;

三、启动eclipse,new server时已经正常。

版权声明:本文为博主原创文章,未经博主允许不得转载。

解决Eclipse添加新server时无法选择Tomcat7的问题

当eclipse中无法创建Tomcat 6或者7时,该如何解决。

eclipse的new server里tomcat7.0根本选不上解决方法

创建Tomcat v7.0 Server 不能进行下一步。 解决方法: 1.退出 eclipse 2.到[工程目录下]/.metadata/.plugins/org.eclipse.core.run...
  • luoww1
  • luoww1
  • 2015年09月08日 14:43
  • 4064

Eclispse中Run on Server窗口让选择Server,但已经存在的选择不了

对于这种问题,通常是因为版本不匹配造成的。jdk版本,Dynamic Web Modules版本。只要改到相应版本就好了,jdk7  时Dynamic Web Modules应设为2.5。如果无法修...

Delphi7高级应用开发随书源码

  • 2003年04月30日 00:00
  • 676KB
  • 下载

eclipse里面找不到server选项

一般的eclipse当然没有了,如果是j2ee版,或者装了web插件,或者是myeclipse的话才有这个选项 SDK 的 Eclipse 版本没有 Server 选项的,得下载 Java EE 版本...
  • xyy511
  • xyy511
  • 2015年06月11日 14:54
  • 36326

eclipse的new server里tomcat7.0根本点不动解决方案

首先这是网友给出的答案,我试了但是没能解决 1.退出 eclipse 2.到[工程目录下]/.metadata/.plugins/org.eclipse.core.runtime 3.把org...

eclipse 中创建web project,Runtime Environment无法选择Tomcat

在Eclipse---Preferences---server---Runtime Environment中,点击“Add”按钮,里面看不到tomcat的,只有个“J2EE Runtime Libra...

myeclipse项目不能部署,选了tomcat6不让finish

myeclipse项目部署的时候,选了tomcat6不让finish的解决方案。如图所示: 此时的Deploy Location为空,Finish键置灰不可点。 解决办法: 在Web Contex...
  • zyz0678
  • zyz0678
  • 2013年07月04日 11:54
  • 2589

Eclipse Server Runtime Environments 中不现实Tomcat的解决办法

Apache Tomcat Not Showing in Eclipse Server Runtime Environments   In my case I needed to install ...
  • shazilv
  • shazilv
  • 2012年03月27日 03:12
  • 7410

在eclipse中使用run->run on server的时候,选择tomcat6会报错误:

1.错误: 在eclipse中使用run->run on server的时候,选择tomcat6会报错误:The server does not support version 3.0 of t...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:解决eclipse的new server里tomcat 无法选择问题
举报原因:
原因补充:

(最多只允许输入30个字)