hdu1061 Rightmost Digit

Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29900    Accepted Submission(s): 11382


Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the rightmost digit of N^N.
 

Sample Input
  
  
2 3 4
 

Sample Output
  
  
7 6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
 


//============================================================================
// Name        : Math_hdu1061.cpp
// Author      : vit
// Version     :
// Copyright   : Your copyright notice
// Description : Hello World in C++, Ansi-style
//============================================================================

#include <iostream>
using namespace std;

int nu[10] = { 1, 1, 4, 4, 2, 1, 1, 4, 4, 2 };//找规律

int main() {
	int t;
	long long a, temp, b;
	cin >> t;
	while (t--) {
		cin >> temp;
		a = temp % 10;
		if (nu[a] == 1) {
			cout << a << endl;
			continue;
		}
		else if (a == 4) {
			cout << '6' << endl;
			continue;
		}
		else if (a == 9){
			cout << '9' << endl;
			continue;
		}
		b = temp % nu[a];
		if(a == 2){
			switch(b){
			case 0:
				cout << '6' << endl;
				break;
			case 1:
				cout << '2' << endl;
				break;
			case 2:
				cout << '4' << endl;
				break;
			case 3:
				cout << '8' << endl;
				break;
			default:
				break;
			}
		}
		else if(a == 3){
			switch(b){
			case 0:
				cout << '1' << endl;
				break;
			case 1:
				cout << '3' << endl;
				break;
			case 2:
				cout << '9' << endl;
				break;
			case 3:
				cout << '7' << endl;
				break;
			default :
				break;
			}
		}
		else if(a == 8){
			switch(b){
			case 0:
				cout << '6' << endl;
				break;
			case 1:
				cout << '8' << endl;
				break;
			case 2:
				cout << '4' << endl;
				break;
			case 3:
				cout << '2' << endl;
				break;
			default:
				break;
			}
		}
		else if(a == 7){
			switch(b){
			case 0:
				cout << '1' << endl;
				break;
			case 1:
				cout << '7' << endl;
				break;
			case 2:
				cout << '9' << endl;
				break;
			case 3:
				cout << '3' << endl;
				break;
			default:
				break;
			}
		}

	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值