如何解决It's likely you're attempting to run Eclipse using the JRE instead of the JDK

原创 2017年09月27日 00:08:04
最近为了维护一个老项目,需要用到一个插件,在安装插件后运行该插件出现eclipse如下报错
It's likely you're attempting to run Eclipse using the JRE instead of the JDK.

具体原因是因为系统安装了最新的JDK1.8,可能JDK1.8对应的JRE有些东西改变了,JDK1.7时没遇到过这种问题。
解决方案一(成功解决问题):
启动eclipse时设置vm参数为javaw(java的窗口运行环境)
eclipse.exe -vm "c:\Program Files\Java\jdk1.8.0_60\bin\javaw.exe"

然后点击eclipse快捷方式启动即可

解决方案二
1. 配置环境变量(windows系统示例)
设置JAVA_HOME变量
JAVA_HOME=C:\Program Files\Java\jdk1.8.0_101
设置PATH变量
PATH=%JAVA_HOME%\bin;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem
这里必须注意 JAVA_HOME的路径必须在SystemRoot路径之前,否则会出现运行报错

总结
本人最终选择第一种方案,使用eclipse快捷方式添加启动参数,避免更改windows环境变量引起其他问题。当然后来查看以后发现早已经添加了JAVA_HOME环境变量,只是在设置PATH时JAVA_HOME没有放在SystemRoot路径之前。

resin容器发布的jsp项目在访问时,提示Check that you are using the JDK, not the JRE.

resin容器发布的jsp项目在访问时,提示Check that you are using the JDK, not the JRE.可能原因P.S 最重要一点 创建resin服务器时,应该先改变...
  • qq_17818623
  • qq_17818623
  • 2017年04月05日 15:53
  • 163

Maven Compilation Error:No compiler is provided...you are running on a JRE rather than a JDK

Maven Compilation Error: [ERROR] COMPILATION ERROR : [INFO] ----------------------------------...
  • kingmax54212008
  • kingmax54212008
  • 2016年09月04日 23:43
  • 1066

Maven报错Please ensure you are using JDK 1.4 or above and not a JRE解决方法

在eclipse下用maven编译时,可能报以下提示  Please ensure you are using JDK 1.4 or above and not a JRE (the com.sun....
  • u011851478
  • u011851478
  • 2016年06月26日 11:24
  • 6848

Maven经典错误之一:Please ensure you are using JDK 1.4 or above and not a JRE

在Eclipse/MyEclipse 下用maven编译时,失败,提示 : Please ensure you are using JDK 1.4 or above and not a JRE...
  • qianqian901108_
  • qianqian901108_
  • 2016年02月24日 10:31
  • 938

eclipse下maven打包失败(Please ensure you are using JDK 1.4 or above and not ......

eclipse下maven打包失败(Please ensure you are using JDK 1.4 or above and not a JRE (the com.s)
  • Paulangsky
  • Paulangsky
  • 2016年11月22日 11:04
  • 1712

a java runtime environment jre or java development kit jdk must be available in order to run eclipse

a java runtime environment jre or java development kit jdk must be available in order to run eclipse...
  • xtm_rongbing
  • xtm_rongbing
  • 2014年03月29日 18:20
  • 2728

Maven报错Please ensure you are using JDK 1.4 or above and not a JRE解决方法!

在eclipse下用maven编译时,很有可能出现以下错误: Please ensure you are using JDK 1.4 or above and not a JRE (the com...
  • weinichendian
  • weinichendian
  • 2017年03月17日 09:13
  • 411

解决Perhaps you are running on a JRE rather than a JDK?问题

Maven-No compiler is provided in this environment. Perhaps you are running on a JRE rather than a JD...
  • lxlhu
  • lxlhu
  • 2015年04月15日 11:50
  • 5240

ORACLE 11G 安装./runInstaller报错"You are attempting to install 64-bit Oracle on a 32-bit operating

准备安装oracle数据库,参考:http://blog.csdn.net/mchdba/article/details/430860371,解决方法(1),忽略系统prereqs[root@powe...
  • mchdba
  • mchdba
  • 2015年02月05日 20:17
  • 5027

maven:Perhaps you are running on a JRE rather than a JDK

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.2:compile (default-c...
  • HaiPaner
  • HaiPaner
  • 2015年01月31日 19:01
  • 1367
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:如何解决It's likely you're attempting to run Eclipse using the JRE instead of the JDK
举报原因:
原因补充:

(最多只允许输入30个字)