UVa 568 Just the Facts (数论&打表&不打表)

262 篇文章 0 订阅
100 篇文章 0 订阅

568 - Just the Facts

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=100&page=show_problem&problem=509

The expression N!, read as ``N factorial," denotes the product of the first N positive integers, where N is nonnegative. So, for example,

NN!
01
11
22
36
424
5120
103628800

For this problem, you are to write a program that can compute the last non-zero digit of any factorial for ($0 \le N \le 10000$). For example, if your program is asked to compute the last nonzero digit of 5!, your program should produce ``2" because 5! = 120, and 2 is the last nonzero digit of 120.

Input 

Input to the program is a series of nonnegative integers not exceeding 10000, each on its own line with no other letters, digits or spaces. For each integer  N , you should read the value and compute the last nonzero digit of  N !.

Output 

For each integer input, the program should print exactly one line of output. Each line of output should contain the value  N , right-justified in columns 1 through 5 with leading blanks, not leading zeroes. Columns 6 - 9 must contain ``  ->  " (space hyphen greater space). Column 10 must contain the single last non-zero digit of  N !.

Sample Input 

1
2
26
125
3125
9999

Sample Output 

    1 -> 1
    2 -> 2
   26 -> 4
  125 -> 8
 3125 -> 2
 9999 -> 8

方法1:打表。根据数据范围,计算时保留最后5位就行。

方法2:计算N!的素因子分解中5的幂的个数count,然后能被2整除的数要除以2直到达到count


先放上打表的算法:

/*0.016s*/

#include<cstdio>

int a[10001] = {1};/// 0!=1

int main()
{
	int i, x;
	for (i = 1; i <= 10000; i++)
	{
		a[i] = a[i - 1] * i;
		while (a[i] % 10 == 0) a[i] /= 10;
		a[i] %= 100000;///根据数据范围,保留最后5位就行~
	}
	while (~scanf("%d", &x))
		printf("%5d -> %d\n", x, a[x] % 10);
	return 0;
}

然后是不打表的算法:

/*0.016s*/

#include<cstdio>

int p[10000];

int main()
{
	int n;
	while (~scanf("%d", &n))
	{
		int i, sum = 1, count = 0, tem = 0;
		if (n == 0)
		{
			printf("    0 -> 1\n");
			continue;
		}
		for (i = 0; i < n; i++) p[i] = i + 1;
		for (i = 0; i < n; i++)
			while (true)
			{
				if (p[i] % 5 == 0)
				{
					p[i] /= 5;
					count++;
				}
				else break;
			}
		for (i = 0; i < n; i++)
		{
			while (true)
			{
				if (p[i] % 2 == 0)
				{
					p[i] /= 2;
					tem++;
				}
				if (p[i] % 2 || tem == count)
					break;
			}
			if (tem == count)
				break;
		}
		for (i = 0; i < n; i++)
		{
			sum *= p[i];
			sum %= 10;
		}
		printf("%5d -> %d\n", n, sum);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值