HDU 4497 GCD and LCM (数论&组合数学)

GCD and LCM

http://acm.hdu.edu.cn/showproblem.php?pid=4497

Time Limit: 2000/1000 MS (Java/Others)    

Memory Limit: 65535/65535 K (Java/Others)


Problem Description
Given two positive integers G and L, could you tell me how many solutions of (x, y, z) there are, satisfying that gcd(x, y, z) = G and lcm(x, y, z) = L? 
Note, gcd(x, y, z) means the greatest common divisor of x, y and z, while lcm(x, y, z) means the least common multiple of x, y and z. 
Note 2, (1, 2, 3) and (1, 3, 2) are two different solutions.
 

Input
First line comes an integer T (T <= 12), telling the number of test cases. 
The next T lines, each contains two positive 32-bit signed integers, G and L. 
It’s guaranteed that each answer will fit in a 32-bit signed integer.
 

Output
For each test case, print one line with the number of solutions satisfying the conditions above.
 

Sample Input
  
  
2 6 72 7 33
 

Sample Output
  
  
72 0
 

Source

部分思路来自之前的一道题(UVa 10892题解)。

解释下这里的6是怎么来的:

设L/G=(p1^r1)*(p2^r2)*(p3^r3)…(pm^rm)

又设

x=(p1^i1)*(p2^i2)*(p3^i3)…(pm^im)

y=(p1^j1)*(p2^j2)*(p3^j3)…(pm^jm)

z=(p1^k1)*(p2^k2)*(p3^k3)…(pm^km)

对于某个r,i、j、k里面一定有一个是r,并且一定有一个是0,所以i,j,k有一下3种情况:

r 0 0 ,有C(3,1)种
r 0 r ,有C(3,1)种
r 0 1~r-1 ,有(r-1)*A(3,3)种

所以一共是6*r种。


完整代码:

/*15ms,200KB*/

#include<cstdio>

int main()
{
	int t;
	long long m, n, ans, i, count;
	scanf("%d", &t);
	while (t--)
	{
		scanf("%I64d%I64d", &m, &n);
		if (n % m) puts("0");///注意特判
		else
		{
			n /= m;
			ans = 1;
			for (i = 2; i * i <= n; i += 2)///不用求素数,因为范围很小(注意n在不断减小)
			{
				if (n % i == 0)
				{
					count = 0;
					while (n % i == 0)
					{
						n /= i;
						++count;
					}
					ans *= 6 * count;
				}
				if (i == 2)
					--i;///小技巧
			}
			if (n > 1) ans *= 6;
			printf("%I64d\n", ans);
		}
	}
	return 0;
}

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值