HDU 1496 Equations (hash)

59 篇文章 0 订阅
1 篇文章 0 订阅

Equations

http://acm.hdu.edu.cn/showproblem.php?pid=1496


Time Limit: 6000/3000 MS (Java/Others)    

Memory Limit: 32768/32768 K (Java/Others)


Problem Description
Consider equations having the following form: 

a*x1^2+b*x2^2+c*x3^2+d*x4^2=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.

It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.

Determine how many solutions satisfy the given equation.
 

Input
The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.
 

Output
For each test case, output a single line containing the number of the solutions.
 

Sample Input
  
  
1 2 3 -4 1 1 1 1
 

Sample Output
  
  
39088 0
 

Author
LL
 

Source

思路:首先,暴力会TLE,所以要把4个数分成2个和2个(关于这一点请阅读《挑战程序设计竞赛》)。注意到a*x1^2+b*x2^2的范围大小为2000000,我们不妨遍历前两个数,计算并记录在一个数组hash[]后,再遍历后两个数,并在hash[]中直接查找,这样复杂度就为O(n^2)(n=100)


完整代码:

/*187ms,8044KB*/

#include<cstdio>
#include<cstring>
const int maxn = 1000000;

int hash[2 * maxn + 5];

int main()
{
	int a, b, c, d, i, j;
	long long ans;
	while (~scanf("%d%d%d%d", &a, &b, &c, &d))
	{
		if (a > 0 && b > 0 && c > 0 && d > 0 || a < 0 && b < 0 && c < 0 && d < 0)
		{
			puts("0");
			continue;
		}
		memset(hash, 0, sizeof(hash));
		for (i = 1; i <= 100; ++i)
			for (j = 1; j <= 100; ++j)
				++hash[a * i * i + b * j * j + maxn];
		ans = 0L;
		for (i = 1; i <= 100; ++i)
			for (j = 1; j <= 100; ++j)
				ans += hash[-c * i * i - d * j * j + maxn];
		printf("%I64d\n", ans << 4);
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值