POJ 1984 Navigation Nightmare (离线并查集)

129 篇文章 0 订阅
20 篇文章 1 订阅


Navigation Nightmare

Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 4599 Accepted: 1734
Case Time Limit: 1000MS

Description

Farmer John's pastoral neighborhood has N farms (2 <= N <= 40,000), usually numbered/labeled 1..N. A series of M (1 <= M < 40,000) vertical and horizontal roads each of varying lengths (1 <= length <= 1000) connect the farms. A map of these farms might look something like the illustration below in which farms are labeled F1..F7 for clarity and lengths between connected farms are shown as (n):
           F1 --- (13) ---- F6 --- (9) ----- F3

            |                                 |

           (3)                                |

            |                                (7)

           F4 --- (20) -------- F2            |

            |                                 |

           (2)                               F5

            | 

           F7 

Being an ASCII diagram, it is not precisely to scale, of course.

Each farm can connect directly to at most four other farms via roads that lead exactly north, south, east, and/or west. Moreover, farms are only located at the endpoints of roads, and some farm can be found at every endpoint of every road. No two roads cross, and precisely one path
(sequence of roads) links every pair of farms.

FJ lost his paper copy of the farm map and he wants to reconstruct it from backup information on his computer. This data contains lines like the following, one for every road:

There is a road of length 10 running north from Farm #23 to Farm #17
There is a road of length 7 running east from Farm #1 to Farm #17
...

As FJ is retrieving this data, he is occasionally interrupted by questions such as the following that he receives from his navigationally-challenged neighbor, farmer Bob:

What is the Manhattan distance between farms #1 and #23?

FJ answers Bob, when he can (sometimes he doesn't yet have enough data yet). In the example above, the answer would be 17, since Bob wants to know the "Manhattan" distance between the pair of farms.
The Manhattan distance between two points (x1,y1) and (x2,y2) is just |x1-x2| + |y1-y2| (which is the distance a taxicab in a large city must travel over city streets in a perfect grid to connect two x,y points).

When Bob asks about a particular pair of farms, FJ might not yet have enough information to deduce the distance between them; in this case, FJ apologizes profusely and replies with "-1".

Input

* Line 1: Two space-separated integers: N and M



* Lines 2..M+1: Each line contains four space-separated entities, F1,

        F2, L, and D that describe a road. F1 and F2 are numbers of

        two farms connected by a road, L is its length, and D is a

        character that is either 'N', 'E', 'S', or 'W' giving the

        direction of the road from F1 to F2.



* Line M+2: A single integer, K (1 <= K <= 10,000), the number of FB's

        queries



* Lines M+3..M+K+2: Each line corresponds to a query from Farmer Bob

        and contains three space-separated integers: F1, F2, and I. F1

        and F2 are numbers of the two farms in the query and I is the

        index (1 <= I <= M) in the data after which Bob asks the

        query. Data index 1 is on line 2 of the input data, and so on.

Output

* Lines 1..K: One integer per line, the response to each of Bob's

        queries.  Each line should contain either a distance

        measurement or -1, if it is impossible to determine the

        appropriate distance.

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S
3
1 6 1
1 4 3
2 6 6

Sample Output

13
-1
10

Hint

At time 1, FJ knows the distance between 1 and 6 is 13.
At time 3, the distance between 1 and 4 is still unknown.
At the end, location 6 is 3 units west and 7 north of 2, so the distance is 10.

Source

USACO 2004 February

题目链接:http://poj.org/problem?id=1984

题目大意:在一个图中,只有上下左右四个方向的边。给出这样的一些边,求任意2个节点之间的曼哈顿距离。

题目分析:代权并查集,由于要根据时间来判断当前状态,又题目说了查询时间是递增的,我们不妨先把输入的信息存储下来,根据查询的时间来将信息加入集合中,设定两个数组x[i],y[i]分别表示i点相对于原点(这里的原点即我们设定的根结点)的横坐标和纵坐标,方向就同二维坐标系一样,通过方向来改变坐标值,压缩路径时要更新w[i]的值,合并的过程和CD题相同,采用向量法。
r1->r2 = r1->a + a->b + b->r2,因为w[i]表示i对原点的偏移量,所以w[r2] = w[a] + d -w[b],若两点在同一集合中直接计算出其曼哈顿距离,若两点不在同一集合中,说明不连通,则输出-1
模拟一遍样例,这里是执行完Find(1-7)以后的坐标
t = 1:   x[1] = 0,   y[1] = 0
           x[6] = 13, y[6] = 0

t = 2:   x[1] = 0,   y[1] = 0
          
x[6] = 13, y[6] = 0
           x[3] = 22, y[3] = 0

t = 3:   x[1] = 0,   y[1] = 0
           x[6] = 13, y[6] = 0
          
x[3] = 22, y[3] = 0
           x[5] = 22, y[5] = -7

t = 4(换原点):
           x[4] = 0,   y[4] = 0
           x[1] = 0,   y[1] = 3
           x[6] = 13, y[6] = 3
           x[3] = 22, y[3] = 3
           x[5] = 22, y[5] = -4

t = 5(换原点):
           x[2] = 0,   y[2] = 0
           x[4] = -20,y[4] = 0
           x[1] = -20,y[1] = 3
           x[6] = -7,  y[6] = 3
           x[3] = 2,   y[3] = 3
           x[5] = 2,   y[5] = -4

t = 6:   x[2] = 0,   y[2] = 0
           x[4] = -20,y[4] = 0
           x[1] = -20,y[1] = 3
           x[6] = -7,  y[6] = 3
           x[3] = 2,   y[3] = 3
           x[5] = 2,   y[5] = -4
           x[7] = -20,y[7] = -2


#include <cstdio>
#include <cstring>
int const MAX = 40005;
int fa[MAX], x[MAX], y[MAX];
int n, m, k;
char get[MAX][50];

void UF_set()
{
    for(int i = 0; i <= n; i++)
    {
        fa[i] = i;
        x[i] = y[i] = 0;
    }
}

int Find(int nd)
{
    if(nd == fa[nd])
        return nd;
    int tmp = fa[nd];
    fa[nd] = Find(fa[nd]);
    x[nd] += x[tmp];
    y[nd] += y[tmp];
    return fa[nd];
}

void Union(int a, int b, int dx, int dy)
{
    int r1 = Find(a);
    int r2 = Find(b);
    if(r1 != r2)
    {
        fa[r2] = r1;
        x[r2] = x[a] + dx - x[b];
        y[r2] = y[a] + dy - y[b]; 
    }
}

int abs(int a)
{
    return a > 0 ? a : -a;
}

int dis(int x1, int x2, int y1, int y2)
{
    return abs(x1 - x2) + abs(y1 - y2);
}

int main()
{
    scanf("%d %d", &n, &m);
    UF_set();
    getchar();
    for(int i = 0; i < m; i++)
        gets(get[i]);
    scanf("%d", &k);
    int nd1, nd2, ct, cur = 0;
    while(k--)
    {
        int a, b, d;
        scanf("%d %d %d", &nd1, &nd2, &ct);
        for(int i = cur; i < ct; i++)
        {
            int dx = 0, dy = 0;
            char dir[2];
            sscanf(get[i], "%d %d %d %s", &a, &b, &d, dir);
            switch(dir[0])
            {
                case 'E': dx += d; break;
                case 'W': dx -= d; break;
                case 'N': dy += d; break;
                case 'S': dy -= d; break;
            }
            Union(a, b, dx, dy);
        }
        cur = ct;
        //这两步很重要,不只是找到r1和r2的根,还更新了x[],y[],同G题
        int r1 = Find(nd1);
        int r2 = Find(nd2);
        if(r1 != r2)
            printf("-1\n");
        else
            printf("%d\n", dis(x[nd1], x[nd2], y[nd1], y[nd2]));
    }
}


  • 3
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值