pip安装报错:is not a supported wheel on this platform

原创 2017年08月11日 11:35:38

可能的原因1:安装的不是对应Python版本的库,下载的库名中cp27代表python2.7,其它同理。

可能的原因2:这个是我遇到的情况(下载的是对应版本的库,然后仍然提示不支持当前平台)

  我下载到的wordcloud库文件名:

wordcloud‑1.3.2‑cp36‑cp36m‑win32.whl
  使用pip安装(在命令行中):

pip install wordcloud‑1.3.2‑cp36‑cp36m‑win32.whl
  报错:* is not a supported wheel on this platform.
 可能的原因就是下载的文件与python的版本不一样。
 
 方法:在shell中输入import pip; print(pip.pep425tags.get_supported())

[('cp35', 'cp35m', 'win32'), 
('cp35', 'none', 'win32'), 
('py3', 'none', 'win32'),
 ('cp35', 'none', 'any'),
('py34', 'none', 'any'), 
('py33', 'none', 'any'), 
('py32', 'none', 'any'), 
('py31', 'none', 'any'), 
('py30', 'none', 'any')]

这里面的cp35 代表的是 python 是3.5 的版本。

所以我的wordcloud 应该下载的是:
wordcloud‑1.3.2‑cp35‑cp35m‑win32.whl

其它的库也同理可以成功安装,不过也请注意库的依赖。

Tips:
(python库下载地址(库很丰富,下载速度也很快):http://www.lfd.uci.edu/~gohlke/pythonlibs

版权声明:本文为博主原创文章,未经博主允许不得转载。

pip安装报错:is not a supported wheel on this platform

可能的原因1:安装的不是对应python版本的库,下载的库名中cp27代表python2.7,其它同理。 可能的原因2:这个是我遇到的情况(下载的是对应版本的库,然后仍然提示不支持当前平台) ...

[Python]Numpy安装及一些玄学问题(is not a supported wheel on this platform、Undefined variable from import)

numpy是python的一个科学计算库,可以实现matlab里的数学运算,基本是用python做数值运算的人必装的一个的库了。 然而今天我安装这个库遇到了一些以前一直没遇到的问题,挺迷的,我之前安装...

安装python出现is not a supported wheel on this platform解决办法

安装python库numpy的时候出现numpy-1.12.1+mkl-cp27-cp27m-win32.whl is not a supported wheel on this platform ...

成功解决安装scikit image出现‘is not a supported wheel on this platform’问题

从http://www.lfd.uci.edu/~gohlke/pythonlibs/上面下载的python包都是已经编译好的包。 但是这次安装从上述网站上下载下来的scikit image的包时,...

Pillow-3.4.2-cp35-cp35m-win_amd64.whl is not a supported wheel on this platform解决办法

可能的原因1:安装的不是对应python版本的库,下载的库名中cp35代表python3.5,其它同理。 可能的原因2:这个是我遇到的情况(下载的是对应版本的库,然后仍然提示不支持当前平台)...

Python爬虫系列之----Scrapy(三)win10下安装Python 3.6.1+Scrapy 1.1.0rc3

111

pip install whl 错误版本解决(暨在win7 python3下装 opencv)

非常感谢博客:http://www.cnblogs.com/nice-forever/p/5371906.html,同时感谢stackoverflow非官方的python库  http://www.l...

pip 安装报错,is not a supported wheel on this platform

可能的原因1:安装的不是对应python版本的库,下载的库名中cp27代表python2.7,其它同理。 可能的原因2:这个是我遇到的情况(下载的是对应版本的库,然后仍然提示不支持当前平台)   ...

Tensorflow二进制安装 && 失败

报错: tensorflow-0.5.0-cp27-none-linux_x86_64.whl is not a supported wheel on this platform. 解决: w...
  • kevinew
  • kevinew
  • 2016年05月27日 19:58
  • 6036
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:pip安装报错:is not a supported wheel on this platform
举报原因:
原因补充:

(最多只允许输入30个字)