The model used to open the store is incompatible with the one used to create the store

原创 2015年07月10日 08:39:48

我们修改了Data Model文件,增加了新的Entity,包括Attribute属性、Relationship关系等等。

解决办法:

(1) 最简单的办法是,在iOS 5 或者 6的模拟器中,删除App,然后重新运行就可以了。

(2) 第二种办法是使用Data Model 数据模型的版本属性:

给Data Model(也就是被管理对象模型)添加一个新的版本:

  1. 在项目导航栏中,选择Data Model 文件;
  2. 选择 Editor > Create Model Version 菜单项;
  3. 在对话框中,输入Data Model文件的名称,并点击Save按钮;

然后设置 Data Model的当前版本号:

  1. 在项目导航栏中,选择Data Model文件;
  2. 在File inspector 面板窗口,找到Versioned Core Data Model 节点;
  3. 从弹出菜单中,选择当前模板版本号;

版权声明:本文为博主原创文章,未经博主允许不得转载。

相关文章推荐

CoreData报错:The model used to open the store is incompatible with the one used to create the store

今天在调试coredata,出现了这个异常: 在推酷看到解决方法:这个错误通常是我们修改了DataModel文件,增加了新的Entity,包括Attribute属性、Relationship关系等等...

(gedit:1962): Gtk-WARNING **: Attempting to store changes into `/root/.local/share/recently-used.xbe

解决方案: 使用 sudo mkdir -p /root/.local/share/命令创建目录: /root/.local/share 这两天捣腾Ubuntu11.10的时候,...

This version of android studio is incompatible with the gradle version used.

Error running app: This version of Android Studio is incompatible with the Gradle Plu...

Error running app: This version of Android Studio is incompatible with the Gradle Plugin used. Try d

在开发中从代码仓库导入项目时,突然遇到个问题, 就是cline 和 Rebuile 都没有问题 ,但是一运行就报Error running app: This version of Android ...

Error running app: This version of Android Studio is incompatible with the Gradle Plugin used. Try d

问题背景 因为项目app分包需要,将工程的graddle版本升至了2.2.0 alpha4,而我的Android studio 一向升级为最新版,于是就出现了题目中的报错: Error run...

This version of Android Studio is incompatible with the Gradle Plugin used.

今天因为该问题导致,我花费了一天的时间。不过也因此学到了东西,不怕问题,没有解决不了的问题。找准问题所在,一定能解决。 我们直接进去正题, 英文:This version of Android ...

AndroidStudio运行项目出现This version of Android Studio is incompatible with the Gradle Plugin used.

问题描述: 我在gitHub上新下载了一个Demo,可是运行时发现有这个错误,在它的 gradle-wrapper.properties 这个文件夹中发现它的gradle版本是3.3的,而我的grad...

This version of android studio is incompatible with the gradle version used.

问题背景 因为项目app分包需要,将工程的graddle版本升至了2.2.0 alpha4,而我的android studio 一向升级为最新版,于是就出现了题目中的报错: Error running...

This version of Android Studio is incompatible with the Gradle Plugin used

问题背景 因为项目app分包需要,将工程的graddle版本升至了2.2.0 alpha4,而我的Android studio 一向升级为最新版,于是就出现了题目中的报错: Error running...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:深度学习:神经网络中的前向传播和反向传播算法推导
举报原因:
原因补充:

(最多只允许输入30个字)