【POJ 2001】Shortest Prefixes(字典树)

Shortest Prefixes

Time Limit: 1000MS Memory Limit: 30000K

Description

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of “carbon” are: “c”, “ca”, “car”, “carb”, “carbo”, and “carbon”. Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, “carbohydrate” is commonly abbreviated by “carb”. In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents.

In the sample input below, “carbohydrate” can be abbreviated to “carboh”, but it cannot be abbreviated to “carbo” (or anything shorter) because there are other words in the list that begin with “carbo”.

An exact match will override a prefix match. For example, the prefix “car” matches the given word “car” exactly. Therefore, it is understood without ambiguity that “car” is an abbreviation for “car” , not for “carriage” or any of the other words in the list that begins with “car”.

Input

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

Output

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.

Sample Input

carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate

Sample Output

carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona

题目大意:给你一些单词作为你的字典,然后你将各个单词的能唯一识别这个单词的前缀找出来。
分析:在字典树结构中加入一个记录数量的变量V。然后输出它的前缀,直到记录完一个单词出现作为前缀。

#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"
#include "cstdlib"

using namespace std;

const int maxn = 1e3+5;
const int MAX = 26;

char s[maxn][MAX];

struct Trie{
    int v;
    bool exit;
    Trie *next[MAX];
    Trie(){
        v = 0;
        exit = false;
        memset(next,0,sizeof(next));
    }
};

Trie *root = new Trie();

void Insert_Trie( char *str ){
    Trie *p = root;
    for( int i=0 ; i<strlen(str) ; i++ ){
        int num = str[i]-'a';
        if( p->next[num] == NULL ){
            p->next[num] = new Trie();
            p->next[num]->v++;
            p = p->next[num];
        }
        else{
            p->next[num]->v++;
            p = p->next[num];
        }
    }
    p->exit = true;
}

void Qurry_Trie( char *str ){
    Trie *p = root;
    for( int i=0 ; i<strlen(str) ; i++ ){
        printf("%c",str[i]);
        int num = str[i]-'a';
        p = p->next[num];
        if(  p->v==1 ){
            puts("");
            return;
        }
    }
    puts("");
    return;
}

int main(){
    int k = 0;
    while( scanf("%s",s[k]) != EOF ){
        Insert_Trie(s[k++]);
    }
    for( int i=0 ; i<k ; i++ ){
        printf("%s ",s[i]);
        Qurry_Trie(s[i]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值