UVA10327 Flip Sort【冒泡排序+逆序偶】

Sorting in computer science is an important part. Almost every problem can be solved effeciently ifsorted data are found. There are some excellent sorting algorithm which has already acheived the lowerbound n · lg n. In this problem we will also discuss about a new sorting approach. In this approachonly one operation (Flip) is available and that is you can exchange two adjacent terms. If you think awhile, you will see that it is always possible to sort a set of numbers in this way.

  A set of integers will be given. Now using the above approach we want to sort the numbers inascending order. You have to find out the minimum number of flips required. Such as to sort ‘1 2 3’we need no flip operation whether to sort ‘2 3 1’ we need at least 2 flip operations.

Input

The input will start with a positive integer N (N ≤ 1000). In next few lines there will be N integers.

  Input will be terminated by EOF.

Output

For each data set print ‘Minimum exchange operations : M’ where M is the minimum flip operationsrequired to perform sorting. Use a seperate line for each case.

Sample Input

3

1 2 3

3

2 3 1

Sample Output

Minimum exchange operations : 0

Minimum exchange operations : 2


问题链接UVA10327 Flip Sort

问题简述:(略)

问题分析:(略)

程序说明

  计算冒泡排序的交换次数,就用冒泡排序来做,只是交换次数多了一些。

  另外一种方法是计算一下逆序偶的数量,出现一个逆序偶就需要一次交换。这种方法不需要做交换,速度比较快一些。

题记:(略)

参考链接:(略)


AC的C语言程序如下(逆序偶):

/* UVA10327 Flip Sort */

#include <stdio.h>

#define N 1000
int a[N];

int main(void)
{
    int n, count, i;

    while(~scanf("%d", &n)) {
        for(i=0; i<n; i++)
            scanf("%d", &a[i]);

        count = 0;
        for(i=0; i<n-1; i++)
            for(int j=i+1; j<n; j++)
                if(a[i] > a[j])
                    count++;

        printf("Minimum exchange operations : %d\n", count);
    }

    return 0;
}

 

AC的C语言程序如下(冒泡排序):

/* UVA10327 Flip Sort */

#include <stdio.h>

#define N 1000
int a[N];

/* 冒泡排序的交换次数 */
int flipsort(int a[], int n)
{
    int count, i, j;

    count = 0;
    for(i=n-1; i > 0; i--) {
        for(j=1; j<=i; j++)
            if(a[j-1] > a[j]) {
                count++;

                /* 交换两个相邻的数 */
                int temp = a[j-1];
                a[j-1] = a[j];
                a[j] = temp;
            }
    }

    return count;
}

int main(void)
{
    int n, i;

    while(~scanf("%d", &n)) {
        for(i=0; i<n; i++)
            scanf("%d", &a[i]);

        printf("Minimum exchange operations : %d\n", flipsort(a, n));
    }

    return 0;
}




  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值