HDU1009 ZOJ2109 FatMouse' Trade【贪心】

232 篇文章 0 订阅
55 篇文章 6 订阅

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 88414    Accepted Submission(s): 30693


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
 
 
5 37 24 35 220 325 1824 1515 10-1 -1
 

Sample Output
 
 
13.333
31.500

问题链接HDU1009 ZOJ2109 FatMouse' Trade

问题简述

  n个房子,每个房间里有老鼠喜欢吃的JavaBean,给出每个房间里JavaBean的重量F[i]和需要的金额F[i]。老鼠使用m元,求m元最多可以买多少javabeans。其中,每个房子的javabeans是可以分割的。

问题分析

  这是一个贪心法的裸题

  每个房间里的JavaBean价格是不同的,需要计算一下。尽可能买价格低的JavaBean就可以买最多的JavaBean。算一下价格,按价格从低到高排一下序就可以了。

程序说明

  需要注意类型转换。

  比较函数中使用的比较符号是">",如果使用">="则在ZOJ中无法AC。

  结构数组中存储整数类型的原始数据是好的做法,计算时再进行类型转换,存储上稍微节省一些。

题记:(略)

参考链接:(略)


AC的C++语言程序如下:

/* HDU1009 ZOJ2109 FatMouse' Trade */

#include <iostream>
#include <algorithm>
#include <stdio.h>

using namespace std;

const int N = 1000;

struct _node {
    int j, f;
    double price;
} nodes[N];

bool cmp(_node& a, _node& b)
{
    return a.price > b.price;
}

int main()
{
    int m, n;

    while(~scanf("%d%d", &m, &n) && (m != -1 || n != -1)) {
        for(int i=0; i<n; i++) {
            scanf("%d%d", &nodes[i].j, &nodes[i].f);
            nodes[i].price = (double)nodes[i].j / nodes[i].f;
        }

        sort(nodes, nodes + n, cmp);

        double max = 0;
        for(int i=0; i<n && m; i++)
            if(m > nodes[i].f) {
                m -= nodes[i].f;
                max += nodes[i].j;
            } else {
                max += (double) m / nodes[i].f * nodes[i].j;
                break;
            }

        printf("%.3f\n", max);
    }

    return 0;
}






  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值