HDU 5316 Magician(线段树区间合并)

Problem Description
Fantasy magicians usually gain their ability through one of three usual methods: possessing it as an innate talent, gaining it through study and practice, or receiving it from another being, often a god, spirit, or demon of some sort. Some wizards are depicted as having a special gift which sets them apart from the vast majority of characters in fantasy worlds who are unable to learn magic.

Magicians, sorcerers, wizards, magi, and practitioners of magic by other titles have appeared in myths, folktales, and literature throughout recorded history, with fantasy works drawing from this background.

In medieval chivalric romance, the wizard often appears as a wise old man and acts as a mentor, with Merlin from the King Arthur stories representing a prime example. Other magicians can appear as villains, hostile to the hero.



Mr. Zstu is a magician, he has many elves like dobby, each of which has a magic power (maybe negative). One day, Mr. Zstu want to test his ability of doing some magic. He made the elves stand in a straight line, from position 1 to position n, and he used two kinds of magic, Change magic and Query Magic, the first is to change an elf’s power, the second is get the maximum sum of beautiful subsequence of a given interval. A beautiful subsequence is a subsequence that all the adjacent pairs of elves in the sequence have a different parity of position. Can you do the same thing as Mr. Zstu ?

 

Input
The first line is an integer T represent the number of test cases.
Each of the test case begins with two integers n, m represent the number of elves and the number of time that Mr. Zstu used his magic.
(n,m <= 100000)
The next line has n integers represent elves’ magic power, magic power is between -1000000000 and 1000000000.
Followed m lines, each line has three integers like 
type a b describe a magic.
If type equals 0, you should output the maximum sum of beautiful subsequence of interval [a,b].(1 <= a <= b <= n)
If type equals 1, you should change the magic power of the elf at position a to b.(1 <= a <= n, 1 <= b <= 1e9)
 

Output
For each 0 type query, output the corresponding answer.
 

Sample Input
  
  
1 1 1 1 0 1 1
 

Sample Output
  
  
1
 

Author
ZSTU
 

Source


 


看一句:A beautiful subsequence is a subsequence that all the adjacent pairs of elves in the sequence have a different parity of position。

意思是说定义美丽子序列是区间里面的一个子序列,这个子序列中任意相邻的两个数在原序列中的具有不同的奇偶性

两种操作,1.把序列x位置的值变成y;2.询问区间[x,y]里面的最大美丽子序列(即序列和最大)


区间合并的时候要满足当左子的美丽子序列如果是以奇位置结尾,那么右子的美丽子序列要以偶开头

若左边以偶结尾,右边则以奇开头

那么只需要保存区间内“偶始偶终”、“偶始奇终”、“奇始偶终”、“奇始奇终”四种美丽子序列,合并的时候奇偶配对着合并

用一个二维数组s[2][2]表示起点和终点的奇偶性,其中0表示偶,1表示奇


还有,其中最大的美丽子序列不可以是空集(意思是说,当最大美丽子序列为负的时候不要取0 。。。。)

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
typedef long long ll;
const int N = 100000;
const ll inf = 1LL<<30LL;
struct Node
{
    int l,r;
    ll s[2][2];//0偶1奇
}q[4*N];
#define ls i<<1
#define rs i<<1|1
void pushup(int i)
{
    for (int j = 0;j <= 1;++j)
    {
        for (int k = 0;k <= 1;++k)
        {
            q[i].s[j][k] = max(q[ls].s[j][k],q[rs].s[j][k]);
            q[i].s[j][k] = max(max(q[ls].s[j][0]+q[rs].s[1][k],q[ls].s[j][1]+q[rs].s[0][k]),q[i].s[j][k]);
        }
    }
}
void build(int i,int l,int r)
{
    q[i].l = l,q[i].r = r;
    if (l == r)
    {
        ll y;
        scanf("%I64d",&y);
        for (int j = 0;j <= 1;++j)
        {
            for (int k = 0;k <= 1;++k)
            {
                q[i].s[j][k] = -inf;
            }
        }
        if (l&1) //奇数
        {
            q[i].s[1][1] = y;
        }
        else q[i].s[0][0] = y;
        return ;
    }
    int mid = (l+r)>>1;
    build(ls,l,mid);
    build(rs,mid+1,r);
    pushup(i);
}
void update(int i,int x,ll y)
{
    if (x == q[i].l &&x == q[i].r)
    {
        if (x&1) //奇数
        {
            q[i].s[1][1] = y;
        }
        else q[i].s[0][0] = y;
        return;
    }
    if (x <= q[ls].r) update(ls,x,y);
    else update(rs,x,y);
    pushup(i);
}
Node query(int i,int l,int r)
{
    if (l<=q[i].l&&q[i].r<=r) return q[i];
    int mid = (q[i].l+q[i].r)>>1;
    if (r <= mid) return query(ls,l,r);
    else if (l > mid) return query(rs,l,r);
    else
    {
        Node ql = query(ls,l,mid);
        Node qr = query(rs,mid+1,r);
        Node ans;
        for (int j = 0;j <= 1;++j)
        {
            for (int k = 0;k <= 1;++k)
            {
                ans.s[j][k] = max(ql.s[j][k],qr.s[j][k]);
                ans.s[j][k] = max(max(ql.s[j][0]+qr.s[1][k],ql.s[j][1]+qr.s[0][k]),ans.s[j][k]);
            }
        }
        return ans;
    }
}
int main()
{
    int T;scanf("%d",&T);
    while (T--)
    {
        int n,m;scanf("%d %d",&n,&m);
        build(1,1,n);
        int op;ll a,b;
        for (int i = 0;i < m;++i)
        {
            scanf("%d",&op);
            scanf("%I64d %I64d",&a,&b);
            if (op == 0)
            {
                Node ans = query(1,(int)a,(int)b);
                ll mx = - inf;
                for (int j = 0;j <= 1;++j)
                {
                    for (int k = 0;k <= 1;++k)
                    {
                        mx = max(ans.s[j][k],mx);
                    }
                }
                printf("%I64d\n",mx);
            }
            else if (op == 1)
            {
                update(1,(int)a,(ll)b);
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
提供的源码资源涵盖了Java应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 适合毕业设计、课程设计作业。这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。 所有源码均经过严格测试,可以直接运行,可以放心下载使用。有任何使用问题欢迎随时与博主沟通,第一时间进行解答!
提供的源码资源涵盖了小程序应用等多个领域,每个领域都包含了丰富的实例和项目。这些源码都是基于各自平台的最新技术和标准编写,确保了在对应环境下能够无缝运行。同时,源码中配备了详细的注释和文档,帮助用户快速理解代码结构和实现逻辑。 适用人群: 适合毕业设计、课程设计作业。这些源码资源特别适合大学生群体。无论你是计算机相关专业的学生,还是对其他领域编程感兴趣的学生,这些资源都能为你提供宝贵的学习和实践机会。通过学习和运行这些源码,你可以掌握各平台开发的基础知识,提升编程能力和项目实战经验。 使用场景及目标: 在学习阶段,你可以利用这些源码资源进行课程实践、课外项目或毕业设计。通过分析和运行源码,你将深入了解各平台开发的技术细节和最佳实践,逐步培养起自己的项目开发和问题解决能力。此外,在求职或创业过程中,具备跨平台开发能力的大学生将更具竞争力。 其他说明: 为了确保源码资源的可运行性和易用性,特别注意了以下几点:首先,每份源码都提供了详细的运行环境和依赖说明,确保用户能够轻松搭建起开发环境;其次,源码中的注释和文档都非常完善,方便用户快速上手和理解代码;最后,我会定期更新这些源码资源,以适应各平台技术的最新发展和市场需求。 所有源码均经过严格测试,可以直接运行,可以放心下载使用。有任何使用问题欢迎随时与博主沟通,第一时间进行解答!

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值