HDU 5323 Solve this interesting problem(dfs结合线段树特点剪枝)

Problem Description
Have you learned something about segment tree? If not, don’t worry, I will explain it for you.
Segment Tree is a kind of binary tree, it can be defined as this:
- For each node u in Segment Tree, u has two values:  Lu  and  Ru .
- If  Lu=Ru , u is a leaf node. 
- If  LuRu , u has two children x and y,with  Lx=Lu , Rx=Lu+Ru2 , Ly=Lu+Ru2+1 , Ry=Ru .
Here is an example of segment tree to do range query of sum.



Given two integers L and R, Your task is to find the minimum non-negative n satisfy that: A Segment Tree with root node's value  Lroot=0  and  Rroot=n  contains a node u with  Lu=L  and  Ru=R .
 

Input
The input consists of several test cases. 
Each test case contains two integers L and R, as described above.
0LR109
LRL+12015
 

Output
For each test, output one line contains one integer. If there is no such n, just output -1.
 

Sample Input
  
  
6 7 10 13 10 11
 

Sample Output
  
  
7 -1 12
 

Author
ZSTU
 

Source
 
题意:
给出区间[l,r]要求找到一棵线段树,使[l,r]是线段树上的一个区间,求满足的线段树中最大区间[0,n]的n
如果有多解,取最小的解
分析:
显然需要自下而上的搜索线段树,对于区间[l,r],它可能是它爸爸的左儿子,也可能是它爸爸的右儿子
当它是左儿子,它爸爸的区间左端点为l,右端点有两种情况(因为对于式子  mid = (l+r)/2 , 同样的mid 有两个(l+r)/2满足条件)
:  rx1 = 2*r - l 或者 rx2 = 2*r +1 - l 
同理,当它是右儿子,它爸爸的区间右端点为r,左端点为: lx1 = 2*(l-1)-r 或 lx2 = 2*(l-1)+1-r
剪枝:1.当前搜索的区间右端点已经大于已知的答案则无需继续,继续下去再找到的答案也必然比已知的答案大
   2.根据 线段树左儿子不可能比右儿子表示的区间长度小 的特点,故当l<(r-l+1)时返回

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
typedef long long ll;
ll ans;
void dfs(ll l,ll r)
{
    if (l == 0)
    {
        if (ans == -1)  ans = r;
        else ans = min(ans,r);
        return;
    }
    if (l < 0) return;
    if (ans != -1&&r >= ans) return;//剪枝1
    //剪枝2:l<(r-l+1)无解,因为线段树左儿子不可能比右儿子表示的区间长度小
    if (l < (r-l+1)) return ;
    //枚举区间[l,r]上一层的区间,[l,r]可能是其爸爸的左儿子,也可能是其爸爸的右儿子
    //对于式子(l+r)/2 = mid,同样的mid 有2个(l+r)/2满足条件
    ll lx1 = 2*(l-1) - r;
    ll lx2 = (2*(l-1))+1 - r;
    ll rx1 = 2*r - l;
    ll rx2 = 2*r+1 - l;
    dfs(lx1,r);
    dfs(lx2,r);
    dfs(l,rx1);
    dfs(l,rx2);
}
int main()
{
    ll l,r;
    while (~scanf("%I64d %I64d",&l,&r))
    {
        ans = -1;
        dfs(l,r);
        printf("%I64d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值