poj2528Mayor's posters【离散化+线段树】

                                                                                                                                   Mayor's posters
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 62773 Accepted: 18121

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:
  • Every candidate can place exactly one poster on the wall.
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
  • The wall is divided into segments and the width of each segment is one byte.
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall.

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed.

The picture below illustrates the case of the sample input.

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4
这道题是运用了线段树的区间优化 和 线段数组的离散化 运用离散化的主要原因就在于可以大大减少额外空间。这道题的解题思路就是 每一张所覆盖的长度都加上同一个颜色
,最后运用hash表进行求解一共可以显示多少种颜色。线段树可以套用区间更新的模板。
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define maxn 10000
int sel[maxn*16];
int li[maxn<<2];
int ri[maxn<<2];
int x[maxn<<2];
int y[maxn<<2];
int hash[maxn<<2];
int ans;
using namespace std; 
int Bin(int ans,int x[],int l,int r){
	while(l<r){
		int m=(l+r)>>1;
		if(x[m]==ans)return m;
		if(ans<=x[m])
		r=m-1;
		else
		l=m+1; 
	}
	return l;
}
void pushdown(int rt){
        if(sel[rt]!=-1){
        	sel[rt<<1]=sel[rt<<1|1]=sel[rt];
        	sel[rt]=-1;
		}	
}
void update(int p,int q,int l,int r,int rt,int c){
       if(p<=l&&q>=r){
       	sel[rt]=c;
       	return;
	   } 
	   pushdown(rt);
	   int m=(l+r)>>1;
	   if(p<=m)
	   update(p,q,l,m,rt<<1,c);
	   if(q>m)
	   update(p,q,m+1,r,rt<<1|1,c);
}
void query(int p,int q,int l,int r,int rt){
	if(sel[rt]!=-1){
		if(hash[sel[rt]]==false){
			ans++;
			hash[sel[rt]]=true;
		}
		sel[rt]=-1;
		return;
	}
	if(l==r)return;
	pushdown(rt);
	int m=(l+r)>>1;
	if(p<=m)
	query(p,q,l,m,rt<<1);
	if(q>m)
	query(p,q,m+1,r,rt<<1|1);
}
int main(){
	int t;
	scanf("%d",&t);
	 while(t--){
	 	int n,i;
        ans=0;
	 	memset(sel,-1,sizeof(sel));
	 	memset(hash,false,sizeof(hash));
	 	scanf("%d",&n);
        int cnt=1;
        for(int i=1;i<=n;i++){
        	scanf("%d%d",&li[i],&ri[i]);
        	x[cnt++]=li[i];
        	x[cnt++]=ri[i];
		}
		sort(x+1,x+cnt);
		int mm=cnt;
		for(int i=2;i<cnt;i++){
			if(x[i]-x[i-1]>1){
				x[mm++]=x[i-1]++;
			}
		}
		sort(x+1,x+mm);
		int tt=2;	
		y[1]=x[1];
		 for(int i=2;i<mm;i++)  
        {  
            if(x[i]!=x[i-1])  
              y[tt++]=x[i];  
        }  
        for(int i=1;i<=n;i++){
        	int l=Bin(li[i],y,1,tt-1);
        	int r=Bin(ri[i],y,1,tt-1);
        	update(l,r,1,tt-1,1,i);
		}
           query(1,tt-1,1,tt-1,1);  
            printf("%d\n",ans);
	 }
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值