HDU1316 How Many Fibs? 【大数】

How Many Fibs?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4961    Accepted Submission(s): 1932

Problem Description
Recall the definition of the Fibonacci numbers:
f1 := 1
f2 := 2
fn := fn-1 + fn-2 (n >= 3)

Given two numbers a and b, calculate how many Fibonacci numbers are in the range [a, b].
 
Input
The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a = b = 0. Otherwise, a <= b <= 10^100. The numbers a and b are given with no superfluous leading zeros.
 
Output
For each test case output on a single line the number of Fibonacci numbers fi with a <= fi <= b.
 
Sample Input
  
  
10 100 1234567890 9876543210 0 0

Sample Output
  
  
5 4
先打表,再转化成字符,再与输入的比较
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<algorithm>
using namespace std;
int F[600][110]={{0},{1},{2}};
char Fi[600][110];
char a[110];
char b[110];
void f()
{
	int i,j,k;
	int c,s;
	for(i=3;i<600;i++)
	{
		for(j=0,c=0;j<110;j++)
		{
			s=F[i-1][j]+F[i-2][j]+c;
			F[i][j]=s%10;
			c=(s-F[i][j])/10;
		}
	}
	for(i=0;i<600;i++)
	{
		k=0;
		for(j=101;F[i][j]==0;j--)
			;
		for(;j>=0;j--)
		{
			Fi[i][k++]=F[i][j]+'0';
		}
		Fi[i][k]='\0';
	}
}
int cmp(char a[], char b[])
{
	int alen=strlen(a),blen=strlen(b);
	int i,j;
	if(alen>blen)
	{
		return 1;
	}
	else if(alen<blen)
	{
		return -1;
	}
	else
	{
		return strcmp(a,b);
	}
}
int main()
{
	int i,j,k;
	int sum;
	char temp[110];
	f();
	while(scanf("%s%s",a,b)!=EOF,a[0]!='0'||b[0]!='0')
	{
		sum=0;
		for(i=0;i<600;i++)
		{
			if(cmp(b,Fi[i])<0)
			{
				break;
			}
			if(cmp(a,Fi[i])<=0)
			{
				sum++;
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值