python2.7安装,及scikit-learn的配置

原创 2015年07月09日 11:02:27

最近换了个电脑用,所以python搞机器学习的一套东西又要重新安装配置。可我却发现这一套流程已经在我遥远的记忆里深埋,所以我要在这里记录一下!

1.下载最新的Python2版本

 可以选择自己想要安装的版本,下载msi文件,并直接安装!:https://www.python.org/downloads/  

个人比较推荐的IDE pycharm,(有功能较为精简适合平时研究的免费版):http://www.jetbrains.com/pycharm/

2.要使用scikit-learn需要先配置numpy,scipy两个模块

numpy网址:http://sourceforge.net/projects/numpy/files/NumPy/1.9.2/

scipy网址:http://sourceforge.net/projects/scipy/files/scipy/0.16.0b2/

直接下载与自己电脑相符的EXE文件。

3.配置scikit-learn

在这里下载合适的scikit-learn安装包:https://pypi.python.org/pypi/scikit-learn/

另附pip的安装与使用网址教程:http://www.360doc.com/content/14/1017/08/10724725_417590569.shtml


Python2.7安装Numpy+Scipy+Matplotlib+Scikit-Learn

Python2.7安装Numpy+Scipy+Matplotlib+Scikit-Learn 系统环境win7 64位,但是python安装的是32位的,因此相关的算法库都是32位的 1、安装Py...
  • gaohuazhao
  • gaohuazhao
  • 2016年09月01日 16:36
  • 647

win7 64安装python2.7.11 和 scikit-learn

学习借鉴: http://www.itnose.net/detail/6418241.html http://blog.csdn.net/u011736505/article/details/51...
  • u010004460
  • u010004460
  • 2016年08月07日 11:28
  • 949

linux下python的机器学习包scikit-learn(包含numpy、scipy等)安装

scikit-learn是python的机器学习包,sci是science的缩写,kit为工具包的意思,实现了常用的机器学习算法。由于依赖许多其他的包,因此安装起来比较麻烦,笔者在十一的最后两天花费了...
  • xiaocanxccc
  • xiaocanxccc
  • 2015年10月07日 17:23
  • 2017

scikit learn环境的搭建(python27+eclipse+pydev+numpy+scipy+maplotib+scitit-learn+jdk)

安装步骤: 1 安装jdk,配置环境变量 2解压eclipse,pydev,将pydev下的两个文件夹copy到eclipse文件夹中 3安装python2.7 4.依次安装numpy,sci...
  • gh624922876
  • gh624922876
  • 2013年12月05日 17:41
  • 1794

windows下安装scikit learn以及python的各种包

每次安装都是不完整,这次配置又出问题,于是决定从头开始安装。 首先,windows7 32位的系统。 首先安装python2.7,官网下载的,安装路径是c:\python2.7 因为之前虽然安...
  • caoeryingzi
  • caoeryingzi
  • 2014年03月04日 10:56
  • 44064

Python学习-安装pip和scikit-learn

服务器环境: centos7.0 python2.7.5 pip-6.1.1 引文:由于之前配集群的时候比较仓促,很多东西都是简化版。python的库都没有安装,今天实验室一同学要用服务器跑程...
  • Dream_angel_Z
  • Dream_angel_Z
  • 2015年05月18日 22:28
  • 9053

Ubuntu14.04下,python配置scikit-learn

Ubuntu14.04下,python配置scikit-learn 1、首先配置基本的python库 sudo apt-get install build-essential ...
  • xiao_lxl
  • xiao_lxl
  • 2016年11月14日 15:45
  • 1563

ubuntu14.04搭建scikit-learn环境及pydev

在Ubuntu14.04环境下,配置机器学习最常用的包scikit-learn, 并在命令行中进行验证安装结果。然后配置Eclipse, 使用最熟悉的IDE - Eclipse作用Python的开发环...
  • sunbibei
  • sunbibei
  • 2016年04月19日 17:24
  • 4024

ubuntu 安装 scikit-learn的注意事项

1、 scikit-learn is tested to work under Python 2.6, Python 2.7, and Python 3.4. (using the same cod...
  • lujiandong1
  • lujiandong1
  • 2015年11月29日 12:51
  • 1103

【修正版】Python基础学习(一)——安装与配置python2.7.x环境(linux)

Linux环境下python的安装/升级方法,且避免系统中因为python升级而影响其编译的命令的使用(如yum命令)...
  • snsdzjlz
  • snsdzjlz
  • 2015年09月04日 18:09
  • 2322
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:python2.7安装,及scikit-learn的配置
举报原因:
原因补充:

(最多只允许输入30个字)