PAT (Advanced Level) 1005. Spell It Right (20) string转int,哈希

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:
12345
Sample Output:
one five
简单的字符串操作。
/*2015.7.19cyq*/
#include <iostream>
#include <string>
#include <sstream>
using namespace std;

string f(string s){
	int sum=0;
	int n=s.size();
	for(int i=0;i<n;i++)
		sum+=s[i]-'0';
	stringstream ss;//将int转为string
	ss<<sum;
	string result;
	ss>>result;
	return result;
}
int main(){
	string a[10]={"zero","one","two","three","four","five","six","seven","eight","nine"};
	string s;
	cin>>s;
	string result=f(s);
	int n=result.size();
	cout<<a[result[0]-'0'];
	for(int i=1;i<n;i++)
		cout<<" "<<a[result[i]-'0'];
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值