poj 3159 Candies(查分约束+堆栈优化的spfa最短路模板)

题目链接:点击打开链接

Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers AB and c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4

Sample Output

5

Hint

32-bit signed integer type is capable of doing all arithmetic.
题目大意:一个班里要分糖果,A同学认为自己分的糖果数要比B同学的糖果数最多少k个,也就是dist[B]-dist[A]<=k,求最大的不同,即从1到n的最短路


ps:由于数据问题,要求的算法比较复杂,用到的为spfa而且是用stack优化的,直接套用他的模板吧,,,建图比较优化,很巧妙,看了好久它的原理

<pre name="code" class="cpp">#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<stack>
#define INF 0x3f3f3f3f

using namespace std ;

struct node
{
    int v,w,next;

}q[150005];

int mp[30005];
bool vis[30005];
int n,m;
int dist[30005];
void spfa()
{
    for(int i=2;i<=n;i++)///初始化为最大
    {
        dist[i]=INF;
    }
    memset(vis,false,sizeof(vis));
    dist[1]=0;///起始点为1,赋值为0
    stack<int >s;///堆栈spfa模板
    s.push(1);
    vis[1]=true;

    while(!s.empty())
    {
        int u=s.top();
        s.pop();

        for(int i=mp[u];i!=0;i=q[i].next)
        {
            int v=q[i].v;
            if(dist[v]>dist[u]+q[i].w)
            {
                dist[v]=dist[u]+q[i].w;
                if(!vis[v])
                {
                    vis[v]=1;
                    s.push(v);
                }
            }
        }
         vis[u]=0;
    }
    printf("%d\n",dist[n]);
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        int x,y,z;
        memset(mp,0,sizeof(mp));
        for(int i=0,j=1;i<m;i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            q[j].v=y;
            q[j].w=z;
            q[j].next=mp[x];
            mp[x]=j++;
        }
        spfa();
    }
    return 0;
}





 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值