PAT 1040. Longest Symmetric String (25)

1040. Longest Symmetric String (25)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given a string, you are supposed to output the length of the longest symmetric sub-string. For example, given "Is PAT&TAP symmetric?", the longest symmetric sub-string is "s PAT&TAP s", hence you must output 11.

Input Specification:

Each input file contains one test case which gives a non-empty string of length no more than 1000.

Output Specification:

For each test case, simply print the maximum length in a line.

Sample Input:
Is PAT&TAP symmetric?
Sample Output:
11

提交代码


/*
	1.用gets(a); 不能用scanf("%s",a); 因为:要读出完整的字符串直至文件末尾,而不是遇到空格就停止此次读。
	2.二重循环搞定。。
	3.找出一个枢轴,以此为中心检测是否对称chen。分奇对称 和 偶对称 2种情况。
*/
#include<stdio.h>
#include<string.h>
const int MAX=1001;
int main()
{
	int i,j;
	char a[MAX];
	//freopen("G:\\in.txt","r",stdin);
	//freopen("G:\\our.txt","w",stdout);
	while(gets(a)){
		int len=strlen(a),tmp=0,ans=0;
		for(i=0;i<len;i++){
			for(j=0;i+j<len,i-j>=0;j++){
				if(a[i-j]==a[i+j]){  //对称子串有奇数个字符
					tmp=2*j+1;
					if(tmp>ans)
						ans=tmp;
				}else                //此句话起决定性作用,加上就25分,否则只有5分。。。。
					break;
			}
		}
		for(i=0;i<len;i++){
			for(j=1;i+j<len,i-j+1>=0;j++){
				if(a[i-j+1]==a[i+j]){  //对称子串有偶数个字符
					tmp=2*j;
					if(tmp>ans)
						ans=tmp;
				}else
					break;
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值