PAT 1015. Reversible Primes (20)

1015. Reversible Primes (20)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No

提交代码


法1:直接判断。考虑边界问题!AC代码


#include<stdio.h>
const int MAX=10010;

int isPrime(int t)
{
	int i;
	if(t==0)
		return 0;
	if(t==1)
		return 0;
	for(i=2;i*i<=t;i++){  //从2开始**************************从0开始由于除数为0会溢出。。
		if(t%i==0)
			return 0;
	}
	return 1;	
}

int reverseNum(int num,int base)
{
	int i,tmp[10],cnt1=0,ret=0;
	do{
		tmp[cnt1++]=num%base;
		num=num/base;
	}while(num!=0);
	for(i=0;i<cnt1;i++)
//		ret+=tmp[i]*pow(base,cnt1-1-i);//n的m次方是double型!!!int会出错
		ret=ret*base+tmp[i];   //累加法
	return ret;
}
int main()
{		
	//freopen("G:\\in.txt","r",stdin);
	int i,j,n,m;
	while(scanf("%d",&n)!=EOF){
		if(n<0) break;
		scanf("%d",&m);
		int reN=reverseNum(n,m);
		if(isPrime(n)==1&&isPrime(reN)==1)
			printf("Yes\n");
		else
			printf("No\n");
	}
    return 0;
}





法2:预处理。汗。。实在找不出问题,18/20,以后再看吧~

#include<stdio.h>
#include<string.h>
#include<stack>
#include<queue>
#include<algorithm>
#include<math.h>
using namespace std;
const int MAX=10010,INF=0x7fffffff;
int ans[MAX],cnt; 
void findPrime()
{
	int i,j,mark[MAX];
	cnt=0;
	memset(mark,0,sizeof(mark));
	for(i=2;i<=10000;i++){
		if(mark[i]==0){
			ans[cnt++]=i;
			for(j=2*i;j<=10000;j=j+i)  //将其倍数标记
				mark[j]=1;
		}
	}
}
int reverseNum(int num,int base)
{
	int i,tmp[10],cnt1=0,ret=0;
	do{
		tmp[cnt1++]=num%base;
		num=num/base;
	}while(num!=0);
	for(i=0;i<cnt1;i++)
//		ret+=tmp[i]*pow(base,cnt1-1-i);//n的m次方是double型!!!int会出错
		ret=ret*base+tmp[i];   //累加法
	return ret;
}
int main()
{		
	//freopen("G:\\in.txt","r",stdin);
	int i,j,n,m;
	while(scanf("%d",&n)!=EOF){
		if(n<0) break;
		scanf("%d",&m);
		findPrime();
		int reN=reverseNum(n,m);
		for(j=0;j<cnt;j++){  //检查原数是否prime
			if(ans[j]==n)
				break;
		}
		for(i=0;i<cnt;i++){  //检查翻转后是否prime
			if(ans[i]==reN)
				break;
		}
		if(i!=cnt&&j!=cnt)
			printf("Yes\n");
		else
			printf("No\n");
	}
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值