POJ 3481 Double Queue

POJ 3481; 链接:http://poj.org/problem?id=3481

题目:

Language:
Double Queue
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9629 Accepted: 4378

Description

The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provided by IBM Romania, and using modern information technologies. As usual, each client of the bank is identified by a positive integer K and, upon arriving to the bank for some services, he or she receives a positive integer priority P. One of the inventions of the young managers of the bank shocked the software engineer of the serving system. They proposed to break the tradition by sometimes calling the serving desk with the lowest priority instead of that with the highest priority. Thus, the system will receive the following types of request:

0The system needs to stop serving
K PAdd client K to the waiting list with priority P
2Serve the client with the highest priority and drop him or her from the waiting list
3Serve the client with the lowest priority and drop him or her from the waiting list

Your task is to help the software engineer of the bank by writing a program to implement the requested serving policy.

Input

Each line of the input contains one of the possible requests; only the last line contains the stop-request (code 0). You may assume that when there is a request to include a new client in the list (code 1), there is no other request in the list of the same client or with the same priority. An identifier K is always less than 106, and a priority P is less than 107. The client may arrive for being served multiple times, and each time may obtain a different priority.

Output

For each request with code 2 or 3, the program has to print, in a separate line of the standard output, the identifier of the served client. If the request arrives when the waiting list is empty, then the program prints zero (0) to the output.

Sample Input

2
1 20 14
1 30 3
2
1 10 99
3
2
2
0

Sample Output

0
20
30
10
0
 
 
 
分析:使用map,可以直接对键值进行排序,可以将优先级作为key,客户端作为value。这样这道题目就很简单了。
 
代码:
#include <iostream>
#include <map>
#include <algorithm>
using namespace std;

map<int, int> m;

int main()
{
	std::ios::sync_with_stdio(false);
	int a, k, p;

	while(cin >> a)
	{
		switch(a)
		{
		case 0: return 0;
		case 1:
			{
				cin >> k >> p;
				m[p] = k;
			}
			break;
		case 2:
			{
				if(m.empty()) cout << 0 << endl;
				else
				{
					cout << (--m.end())->second << endl;
					m.erase(--m.end());
				}
			}
			break;
		case 3:
			{
				if(m.empty()) cout << 0 << endl;
				else
				{
					cout << m.begin()->second << endl;
					m.erase(m.begin());
				}
			}
			break;
		}
	}

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值