[完全背包]HOJ 1031&HDU 1114 Piggy-Bank

传送门:

HOJ Piggy-Bank

HDOJ Piggy-Bank

Piggy-Bank

My Tags  (Edit)
  Source : ACM ICPC Central European Regional 1999
  Time limit : 5 sec   Memory limit : 32 M

Submitted : 1446, Accepted : 641

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input Specification

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 500001 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.

Output Specification

Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X. where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible..

Sample Input:
3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4
Sample Output:
The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

解题报告:

此题为完整背包问题。状态转移方程:dp[j]=min(dp[j],dp[j-E[i].w]+E[i].p);代码如下:

#include<iostream>
#include<cstring>
#include<cstdio>
#define INF 1<<30
using namespace std;
struct node{
    int w,p;
}E[505];
int dp[10005];
int main(){
    int t,n;
    int e,f;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&e,&f);
        for(int i=1;i<=f;i++)
            dp[i]=INF;
        dp[0]=0;
        f-=e;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%d%d",&E[i].p,&E[i].w);
        for(int i=1;i<=n;i++)
            for(int j=E[i].w;j<=f;j++)
                dp[j]=min(dp[j],dp[j-E[i].w]+E[i].p);
        if(dp[f]==INF)
            printf("This is impossible.\n");
        else
            printf("The minimum amount of money in the piggy-bank is %d.\n",dp[f]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值