HOJ 2022 Mersenne Composite Numbers

Mersenne Composite Numbers

My Tags  (Edit)
  Source : ACM ICPC Pacific Northwest 2004
  Time limit : 1 sec   Memory limit : 32 M

Submitted : 108, Accepted : 67

One of the world-wide cooperative computing tasks is the "Grand Internet Mersenne Prime Search" - GIMPS - striving to find ever-larger prime numbers by examining a particular category of such numbers.

A Mersenne number is defined as a number of the form (2p - 1), where p is a prime number - a number divisible only by one and itself. (A number that can be divided by numbers other than itself and one are called "composite" numbers, and each of these can be uniquely represented by the prime numbers that can be multiplied together to generate the composite number - referred to as its prime factors.)

Initially it looks as though the Mersenne numbers are all primes.

PrimeCorresponding Mersenne Number
2 4-1 = 3 -- prime
3 8-1 = 7 -- prime
5 32-1 = 31 -- prime
7 128-1 = 127 -- prime

If, however, we are having a "Grand Internet" search, that must not be the case.

Where k is an input parameter, compute all the Mersenne composite numbers less than 2k - where k < 63 (that is, it will fit in a 64-bit signed integer on the computer). In Java, the "long" data type is a signed 64-bit integer. Under gcc and g++ (C and C++ in the programming contest environment), the "long long" data type is a signed 64-bit integer.


Input

Input contains a single number, without leading or trailing blanks, giving the value of k. As promised, k < 63.


Output

One line per Mersenne composite number giving first the prime factors (in increasing order) separate by asterisks, an equal sign, the Mersenne number itself, an equal sign, and then the explicit statement of the Mersenne number, as shown in the sample output. Use exactly this format. Note that all separating white space fields consist of one blank.

Sample Input

31
Sample Output
23 * 89 = 2047 = ( 2 ^ 11 ) - 1
47 * 178481 = 8388607 = ( 2 ^ 23 ) - 1
233 * 1103 * 2089 = 536870911 = ( 2 ^ 29 ) - 1

解题报告:

此题就是找出63以内的非梅森素数(只有11 23 29 37 41 43 47 53 59不是梅森素数)。直接找会超时,所以我就邪恶的打表了。代码如下:

#include<stdio.h>
int main(){
    int t;
    scanf("%d",&t);
    printf("23 * 89 = 2047 = ( 2 ^ 11 ) - 1\n");
    printf("47 * 178481 = 8388607 = ( 2 ^ 23 ) - 1\n");
    printf("233 * 1103 * 2089 = 536870911 = ( 2 ^ 29 ) - 1\n");
    printf("223 * 616318177 = 137438953471 = ( 2 ^ 37 ) - 1\n");
    printf("13367 * 164511353 = 2199023255551 = ( 2 ^ 41 ) - 1\n");
    printf("431 * 9719 * 2099863 = 8796093022207 = ( 2 ^ 43 ) - 1\n");
    printf("2351 * 4513 * 13264529 = 140737488355327 = ( 2 ^ 47 ) - 1\n");
    printf("6361 * 69431 * 20394401 = 9007199254740991 = ( 2 ^ 53 ) - 1\n");
    printf("179951 * 3203431780337 = 576460752303423487 = ( 2 ^ 59 ) - 1\n");
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值