树形DP(4) Poj1947 Rebuilding Roads

题目链接:http://poj.org/problem?id=1947 

Rebuilding Roads
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 8566 Accepted: 3835

Description

The cows have reconstructed Farmer John's farm, with its N barns (1 <= N <= 150, number 1..N) after the terrible earthquake last May. The cows didn't have time to rebuild any extra roads, so now there is exactly one way to get from any given barn to any other barn. Thus, the farm transportation system can be represented as a tree.  

Farmer John wants to know how much damage another earthquake could do. He wants to know the minimum number of roads whose destruction would isolate a subtree of exactly P (1 <= P <= N) barns from the rest of the barns.

Input

* Line 1: Two integers, N and P  

* Lines 2..N: N-1 lines, each with two integers I and J. Node I is node J's parent in the tree of roads.  

Output

A single line containing the integer that is the minimum number of roads that need to be destroyed for a subtree of P nodes to be isolated.  

Sample Input

11 6
1 2
1 3
1 4
1 5
2 6
2 7
2 8
4 9
4 10
4 11

Sample Output

2

Hint

[A subtree with nodes (1, 2, 3, 6, 7, 8) will become isolated if roads 1-4 and 1-5 are destroyed.]  


题意:给一颗有N个结点的树,求通过删去最少的边,使得剩下的子树有给定的节点数P。
/*
求减去ans条边,剩下p个结点,求最小的ans;
dp[s][i]:记录s结点,要得到一棵j个节点的子树去掉的最少边数
 考虑其儿子k
 1)如果不去掉k子树,则
 dp[s][i] = min(dp[s][j]+dp[k][i-j])  0 <= j <= i

 2)如果去掉k子树,则
 dp[s][i] =  dp[s][i]+1
 总的为
 dp[s][i] = min (min(dp[s][j]+dp[k][i-j]) ,  dp[s][i]+1 )
*/
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<vector>
using namespace std;
vector<int>vct[155];
bool vis[155];
int dp[155][155];
int n,p;
void solve(int u)
{
	vis[u] = 1;
	int v;
	for (int i = 0; i <= p; i++)
		dp[u][i] = n;
	dp[u][1] = 0; //leaf node
	//if(vct[u].size()==0)dp[u][1]=0;
	for (int x = 0; x < vct[u].size(); x++)
	{
		v = vct[u][x];
		if(!vis[v])
		{
			solve(v);
			for(int i=p;i>=1;i--){
				int Min = dp[u][i]+1;
				for (int j = 1; j < i; j++)
					Min = min(dp[u][j]+dp[v][i-j],Min);
				dp[u][i] = Min;
			}
		}
	}
}
int main()
{
	int u,v;
	while(~scanf("%d%d",&n,&p))
	{
		memset(vis,false,sizeof(vis));
		for (int i = 1; i <= n; i++)
			vct[i].clear();
		for (int i = 1; i < n; i++)
		{
			scanf("%d%d",&u,&v);
			vct[u].push_back(v);
		}
		solve(1);
		int ans = dp[1][p];
		for (int i = 1; i <= n; i++)
			ans = min(ans,dp[i][p]+1);
		printf("%d\n",ans);
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值