hdu1541Stars (线段树,二维变一维)

Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input
  
  
5 1 1 5 1 7 1 3 3 5 5

Sample Output
  
  
1 2 1 1 0
题目意思为:有多组输入,每组第一个输入m,表示有m组数,每组有两个数x,y代表坐标,每个star有独特的位置,每个star的左下方有多少个star代表级别。要求出入从0级到m-1级的数量。
解题:对于多维变一维就是对先后放入的顺序改变一下。先对m组数据以y从小到大排,相等的以x从小到大排,建线段树时先离散化x,以x不重复的个数建树。每插入一个star计算出左下方的数量sum,那么sum就是该star的级别。
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<map>
using namespace std;
#define N 15000
int tree[3*N],sum;
void builde(int l,int r,int k)
{
    int m=(l+r)>>1;
    tree[k]=0;
    if(l==r) return ;
    builde(l,m,k<<1); builde(m+1,r,k<<1|1);
}
void updata(int l,int r,int k,int id)
{
    int m=(l+r)>>1;
    tree[k]++;
    if(l==r)
    {
        sum+=tree[k]-1; return ;
    }
    if(id<=m) updata(l,m,k<<1,id);
    else {
        sum+=tree[k<<1]; updata(m+1,r,k<<1|1,id);
    }
}
struct nn
{
    int x,y;
}node[N+5];
int xx[N+5];
map<int,int>loc;
int cmp1(nn a,nn b)
{
    if(a.y==b.y)
    return a.x<b.x;
    return a.y<b.y;
}
int cmp2(int a,int b)
{return a<b;}
int resort(int n)
{
    sort(xx+1,xx+n+1,cmp2);
    int i,j;
    loc[xx[1]]=1;
    for(i=2,j=1;i<=n;i++)
    if(xx[i]!=xx[j])
    {
        xx[++j]=xx[i]; loc[xx[j]]=j;
    }
    return j;
}
int main()
{
    int n,m,leve[N+5];
    while(scanf("%d",&m)>0)
    {
        n=0;
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&node[i].x,&node[i].y);
            xx[++n]=node[i].x; leve[i-1]=0;
        }
        sort(node+1,node+m+1,cmp1);
        n=resort(n);
        builde(1,n,1);
        for(int i=1;i<=m;i++)
        {
            sum=0;
            updata(1,n,1,loc[node[i].x]);
            leve[sum]++;
        }
        for(int i=0;i<m;i++)
        printf("%d\n",leve[i]);
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值