HDU2377Bus Pass(spfa)

Bus Pass

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 750    Accepted Submission(s): 302


Problem Description
You travel a lot by bus and the costs of all the seperate tickets are starting to add up.

Therefore you want to see if it might be advantageous for you to buy a bus pass.

The way the bus system works in your country (and also in the Netherlands) is as follows:

when you buy a bus pass, you have to indicate a center zone and a star value. You are allowed to travel freely in any zone which has a distance to your center zone which is less than your star value. For example, if you have a star value of one, you can only travel in your center zone. If you have a star value of two, you can also travel in all adjacent zones, et cetera.

You have a list of all bus trips you frequently make, and would like to determine the minimum star value you need to make all these trips using your buss pass. But this is not always an easy task. For example look at the following figure:



Here you want to be able to travel from A to B and from B to D. The best center zone is 7400, for which you only need a star value of 4. Note that you do not even visit this zone on your trips!
 

Input
On the first line an integert(1 <=t<= 100): the number of test cases. Then for each test case:

One line with two integersnz(2 <=nz<= 9 999) andnr(1 <=nr<= 10): the number of zones and the number of bus trips, respectively.

nz lines starting with two integers id i (1 <= id i <= 9 999) and mz i (1 <= mz i <= 10), a number identifying the i-th zone and the number of zones adjacent to it, followed by mz i integers: the numbers of the adjacent zones.

nr lines starting with one integer mr i (1 <= mr i <= 20), indicating the number of zones the ith bus trip visits, followed by mr i integers: the numbers of the zones through which the bus passes in the order in which they are visited.

All zones are connected, either directly or via other zones.

 

Output
For each test case:

One line with two integers, the minimum star value and the id of a center zone which achieves this minimum star value. If there are multiple possibilities, choose the zone with the lowest number.

 

Sample Input
  
  
1 17 2 7400 6 7401 7402 7403 7404 7405 7406 7401 6 7412 7402 7400 7406 7410 7411 7402 5 7412 7403 7400 7401 7411 7403 6 7413 7414 7404 7400 7402 7412 7404 5 7403 7414 7415 7405 7400 7405 6 7404 7415 7407 7408 7406 7400 7406 7 7400 7405 7407 7408 7409 7410 7401 7407 4 7408 7406 7405 7415 7408 4 7409 7406 7405 7407 7409 3 7410 7406 7408 7410 4 7411 7401 7406 7409 7411 5 7416 7412 7402 7401 7410 7412 6 7416 7411 7401 7402 7403 7413 7413 3 7412 7403 7414 7414 3 7413 7403 7404 7415 3 7404 7405 7407 7416 2 7411 7412 5 7409 7408 7407 7405 7415 6 7415 7404 7414 7413 7412 7416
 

Sample Output
  
  
4 7400
 题意要求出一个点到所有的公交站点的最远距离最小,且块的标号最小。
逆向思考,先求出公交站点到所有块的最短距离。再直接枚举每个中心点到所有的公交站点的最大距离最小,并记下该中心点。
#include<stdio.h>
#include<queue>
#include<vector>
using namespace std;
const int N = 10005;
const int inf = 9999999;

vector<int>mapt[N];
int dis[205][N],nz;
void spfa(int k,int s)
{
    queue<int>q;
    for(int i=1;i<=nz;i++)
        dis[k][i]=inf;
    dis[k][s]=1;
    q.push(s);
    while(!q.empty())
    {
        s=q.front(); q.pop();
        for(int i=0;i<mapt[s].size();i++)
        {
            int j=mapt[s][i];
            if(dis[k][j]>dis[k][s]+1)
            {
                dis[k][j]=dis[k][s]+1;
                q.push(j);
            }
        }
    }
}
int main()
{
    int t,id[N],mark[N],go[N],nr,mz,a,kn;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&nz,&nr);
        kn=0;
        for(int i=1;i<N;i++)
            id[i]=0;
        for(int i=1;i<=nz;i++)
            mapt[i].clear();

        for(int i=1;i<=nz;i++)
        {
            scanf("%d%d",&a,&mz);
            if(id[a]==0)
            {
                kn++; id[a]=kn; mark[kn]=a;//每个块标号,及标号代表的块值
            }
            int s=id[a];
            while(mz--)
            {
                scanf("%d",&a);
                if(id[a]==0)
                {
                    kn++; id[a]=kn; mark[kn]=a;
                }
                mapt[s].push_back(id[a]);
            }
        }
        kn=0;
        while(nr--)
        {
            scanf("%d",&mz);
            while(mz--)
            {
                scanf("%d",&a);
                go[++kn]=id[a];
            }
        }

        for(int i=1;i<=kn;i++)
        {
            spfa(i,go[i]);
        }
        int mindis=inf,center;
        for(int cid=1;cid<=nz;cid++)
        {
            int maxdis=0;
            for(int i=1;i<=kn;i++)
                if(dis[i][cid]>maxdis)
                {
                    maxdis=dis[i][cid];
                }
            if(maxdis<mindis)
            {
                mindis=maxdis; center=cid;
            }
            else if(maxdis==mindis&&mark[center]>mark[cid])
                center=cid;
        }
        printf("%d %d\n",mindis,mark[center]);
    }
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值