Internet of Lights and Switches(MAP记录+二分) 2015年湖南省赛第 I 题

题目描述

You are a fan of "Internet of Things"(IoT, 物联网), so you build a nice Internet of Lights and Switches in your huge mansion. Formally, there are n lights and m switches, each switch controls one or more lights, i.e. pressing that switch flips the status of those lights (on->off, off->on).

blob.png

Initially, all the lights are on. Your task is to count the number of ways to turn off all the lights by pressing some consecutive switches. Each switch should not be pressed more than once. There is only one restriction: the number of switches you pressed should be between a and b (inclusive).


输入描述

There will be at most 20 test cases. Each test case begins with a line containing four integers n, m, a, b (2<=n<=50, 1<=a<=b<=m<=300000). Each of the following m lines contains a 01 string of length n. The i-th character is 1 if and only if that switch controls the i-th light. The size of the whole input file does not exceed 8MB.


输出描述

For each test case, print the case number, and the number of ways to turn off all the lights.


输入样例
2 4 1 4
01
10
11
00
2 4 3 3
01
10
11
00
6 3 1 3
101001
010110
101001

输出样例

Case 1: 3 Case 2: 0 Case 3: 2

题意:有n个灯最初是亮的,现在要通过连续的操作使得灯全灭,现在m个操作,可以连续的操作个数为a~b,问有多少种情况使得灯全灭。

解题:用map<long long , vector<int> >记录每种灯的状态所对应第 i 个操作(第i个操作的状态为:输入的前i个操作的异或状态) + 二分.

#include<stdio.h>
#include<string.h>
#include<string>
#include<map>
#include<vector>
using namespace std;
const int N = 300010 ;
#define ll long long
ll num[N] ;
map<ll, vector<int> >mp;
void two(ll tnum , int n , int& L , int& R )
{
    int l=0,r=mp[tnum].size()-1 , mid;
    while(l<=r)
    {
        mid = (l+r)>>1;
        if(mp[tnum][mid]>=L)
            r = mid - 1 ;
        else
            l = mid + 1;
    }
    L  = l ;
    if(L==mp[tnum].size()){
        L = -1 ;
        R =  L - 1 ;
        return ;
    }
    l = 0 , r = mp[tnum].size()-1 ;
    while(l<=r)
    {
        mid = (l+r)>>1;
        if(mp[tnum][mid]>=R)
            r = mid - 1 ;
        else
            l = mid + 1;
    }
    if(l==mp[tnum].size())
        R = l-1;
    else if(mp[tnum][l]>R)
        R = l-1 ;
    else
        R = l ;
}

int main()
{
    int n,m,a,b , ans , T = 0;
    char s[100] ;
    while(scanf("%d%d%d%d",&n,&m,&a,&b)>0){
        mp[0].push_back(0);
        num[0]=0;
        for(int i=1; i<=m; i++){
            scanf("%s",s);
            num[i] = 0 ;
            for(int j=0; j<n; j++)
                if(s[j]=='1'&& !(num[i-1]&(1LL<<j)) || s[j]=='0'&&(num[i-1]&(1LL<<j))==(1LL<<j))
                    num[i] |= 1LL<<j ;

            mp[ num[i] ].push_back(i) ;
           // printf("size = %d\n",mp[num[i]].size());
        }
        ans = 0 ;
        for(int i=1; i<=m; i++){
            ll tnum = 0 ;
            for(int j=0; j<n; j++)
                if((num[i]&(1LL<<j))==0)
                  tnum |= 1LL<<j;
            int L = i-b , R = i-a ;
            two(tnum , n , L , R );
            if(R>=L)
                ans += R-L+1 ;
           // printf("[ %d , %d ] num = %lld ,tnum = %lld size = %d\n",L,R,num[i],tnum,mp[tnum].size());
        }
        for(int i=0; i<=m; i++)
            mp[num[i]].clear() ;

        printf("Case %d: %d\n",++T , ans ) ;
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值