杭电 HDU OJ Max Sum ID1003 AC

Max Sum Accepts: 42553 Submissions: 182219
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Problem Description
Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4

Case 2:
7 1 6
Author
Ignatius.L

#include <stdio.h>
#include <stdlib.h>
__int64 max_sub(int *arr,unsigned int *start,unsigned int *end,unsigned int N);
int _max(int *arr,unsigned int N,unsigned int *p_start,unsigned int *p_end);
int main() {
    //声明变量 
    int T,i,*arr;
    unsigned int N,j;
    unsigned int start,end;
    __int64 sum;
    scanf("%d",&T);
    //外部循环 
    for(i=1;i<=T;i++) {
        scanf("%u",&N);
        //获取N个值 
        arr = (int *)malloc(sizeof(int)*N);
        for(j=0;j<N;j++) {
            scanf("%d",&arr[j]);
        }
        //求解 
        sum = max_sub(arr,&start,&end,N);
        //输出 
        printf("Case %d:\n",i);
        printf("%I64d %u %u\n",sum,start,end);
        if(T>i) printf("\n");
        free(arr);
    }
    return 0;
}
__int64 max_sub(int *arr,unsigned int *p_start,unsigned int *p_end,unsigned int N) {
    __int64 max=0,tmp=0;
    unsigned int i,startt=0;
    int flag = 1;
    //循环求解 
    for(i=0;i<N;i++) {
        //flag=1的时候重新寻找最大子串  
        if(arr[i]>=0&&flag==1){
            startt =i+1;
            flag = 0;
            tmp = arr[i];
        }
        else if(flag==0){
            tmp += arr[i];
        }
        //tmp小于零的时候子串丢弃 
        if(tmp<0){
            flag=1;
        }
        if(max<tmp) {
            max = tmp;
            *p_end = i+1;
            *p_start = startt;
        }
    }
    //全为负数的情况 
    if(startt==0) {
        return _max(arr,N,p_start,p_end);
    }
    else return max;
}
int _max(int *arr,unsigned int N,unsigned int *p_start,unsigned int *p_end) {
    unsigned int i;
    int max=arr[0];
    *p_start = 1;
    *p_end = 1;
    for(i=1;i<N;i++) {
        if(max<arr[i]){
            max = arr[i];
            *p_start=i+1;
            *p_end=i+1;
        }
    }
    return max;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值