poj 2689 Prime Distance(筛素数)

Prime Distance
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10806 Accepted: 2917

Description

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers.
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

Source


题意:求一个范围内相邻2个素数最近和最远的距离,范围不超过一百万,数字不超过2的32次方
题解:晒素数的题目,不过要注意2点trick,一个是范围内可以包括1,一个是2的32次方爆了int,至少要用unsigned int,用long long 也一样,其余就是普通的晒素数问题

#include<stdio.h>
#include<string.h>
#define N 47888
#define inf 0xffffff
int prime[5000],mark[1000008];
long long mind,maxd,min1,min2,max1,max2;
void init()
{
    int i,j,all=0;

    memset(mark,0,sizeof(mark));
    for(i=2;i<N;i++)
    {
        if(mark[i]) continue;
        prime[all++]=i;
        for(j=i*2;j<N;j+=i) mark[j]=1;
    }
}
void solve(long long l,long long u)
{
    long long i,j,temp;

    for(i=l;i<=u;i++)
    {
        if(i==1||(i!=2&&!(i&1))) mark[i-l]=0;
        else mark[i-l]=1;
    }
    for(i=1;(long long)prime[i]*prime[i]<=u;i++)
    {
        temp=l%prime[i]?(prime[i]-l%prime[i]):0;
        if(l+temp==prime[i]) temp+=prime[i];
        for(j=l+temp;j<=u;j+=prime[i]) mark[j-l]=0;
    }
    for(i=l;i<=u;i++) if(mark[i-l]) break;
    for(temp=i,i++;i<=u;i++)
    {
        if(!mark[i-l]) continue;
        if(i-temp>maxd) max1=temp,max2=i,maxd=i-temp;
        if(i-temp<mind) min1=temp,min2=i,mind=i-temp;
        temp=i;
    }
}
int main()
{
    long long l,u;

    init();
    while(scanf("%I64d%I64d",&l,&u)>0)
    {
        mind=inf,maxd=-1;
        solve(l,u);
        if(mind==inf) printf("There are no adjacent primes.\n");
        else
        {
            printf("%I64d,%I64d are closest, ",min1,min2);
            printf("%I64d,%I64d are most distant.\n",max1,max2);
        }
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值