hdu 3336 Count the string(KMP+dp)

                                                  Count the string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2949    Accepted Submission(s): 1375


Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
 

Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
 

Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
 

Sample Input
  
  
1 4 abab
 

Sample Output
  
  
6
 

Author
foreverlin@HNU
 

Source
 

Recommend
lcy


题解:灵活运用KMP的next数组,这里next数组保存以s【i】结尾的最长前缀长度,设dp【i】的值代表0~i的字符中的前缀数,显然0~i的字符的前缀数等于以是s【i】结尾的最长前缀的dp值+1(0~i这个个前缀),这里代码中的表示的长度和下标灵活使用- -比较容易混淆,看多几遍就会懂了....


#include <stdio.h>
#include <string.h>
int next[200005],dp[200005],l;
char s[200005];
void get_next()
{
    int i,temp;

    memset(next,0,sizeof(next));
    for(i=1;i<l;i++)
    {
        temp=next[i-1];
        while(temp&&s[temp]!=s[i])
            temp=next[temp-1];
        if(s[temp]==s[i]) next[i]=temp+1;
        else next[i]=0;
    }
}
int solve()
{
    int i,sum=0;

    get_next();
    for(i=0;i<l;i++) dp[i]=1;
    printf("\n");
    for(i=0;i<l;i++)
    {
        if(next[i]) dp[i]+=dp[next[i]-1];
        sum+=dp[i];
    }

    return sum%10007;
}
int main()
{
    int t;

    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%s",&l,s);
        printf("%d\n",solve());
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值