UVa537 Artificial Intelligence?


  Artificial Intelligence? 

Physics teachers in high school often think that problems given as text are more demanding than pure computations. After all, the pupils have to read and understand the problem first!

So they don't state a problem like ``U=10V, I=5A, P=?" but rather like ``You have an electrical circuit that contains a battery with a voltage of U=10V and a light-bulb. There's an electrical current of I=5A through the bulb. Which power is generated in the bulb?".

However, half of the pupils just don't pay attention to the text anyway. They just extract from the text what is given: U=10V, I=5A. Then they think: ``Which formulae do I know? Ah yes, P=U*I. Therefore P=10V*5A=500W. Finished."

OK, this doesn't always work, so these pupils are usually not the top scorers in physics tests. But at least this simple algorithm is usually good enough to pass the class. (Sad but true.)

Today we will check if a computer can pass a high school physics test. We will concentrate on the P-U-I type problems first. That means, problems in which two of power, voltage and current are given and the third is wanted.


Your job is to write a program that reads such a text problem and solves it according to the simple algorithm given above.

Input 

The first line of the input file will contain the number of test cases.

Each test case will consist of one line containing exactly two data fields and some additional arbitrary words. A data field will be of the form I=xAU=xV or P=xW, where x is a real number.

Directly before the unit (AV or W) one of the prefixes m (milli), k (kilo) and M (Mega) may also occur. To summarize it: Data fields adhere to the following grammar:

DataField ::= Concept '=' RealNumber [Prefix] Unit
Concept   ::= 'P' | 'U' | 'I'
Prefix    ::= 'm' | 'k' | 'M'
Unit      ::= 'W' | 'V' | 'A'

Additional assertions:

  • The equal sign (`=') will never occur in an other context than within a data field.
  • There is no whitespace (tabs,blanks) inside a data field.
  • Either P and UP and I, or U and I will be given.

Output 

For each test case, print three lines:

  • a line saying ``Problem #k" where k is the number of the test case
  • a line giving the solution (voltage, power or current, dependent on what was given), written without a prefix and with two decimal places as shown in the sample output
  • a blank line

Sample Input 

3
If the voltage is U=200V and the current is I=4.5A, which power is generated?
A light-bulb yields P=100W and the voltage is U=220V. Compute the current, please.
bla bla bla lightning strike I=2A bla bla bla P=2.5MW bla bla voltage?

Sample Output 

Problem #1
P=900.00W

Problem #2
I=0.45A

Problem #3
U=1250000.00V



Miguel A. Revilla 
1999-01-11

这题大意就是要从一串字符串中找出已知条件,同时对于不同的条件给出结果,主要就是字符串的分离与提取,我是以=号为标记查找其前面的物理量以及后面的数值和单位。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cctype>
#include <cmath>
using namespace std;

const int N = 1000;

char str[N];

double get_value(char *str,int j) {
	int i = j;
	int d_n = 0;
	int t = 0;
	int len_s = strlen(str);
	double f = 1;
	char tmp[100];
	bool dot = false;
	memset(tmp,0,sizeof(tmp));
	
	for (; i < len_s; i++) {
		if (isdigit(str[i])) {
			tmp[t++] = str[i];
			if (dot)
				d_n++;
		}
		else if (str[i] == '.')
			dot = true;
		else {
			if (str[i] == 'm')
				f = 0.001;
			else if (str[i] == 'k')
				f = 1000;
			else if (str[i] == 'M')
				f = 1000000;
			break;
		}
	}

	int len_t = strlen(tmp);
	double sum = 0;
	for (int i = 0; i < len_t; i++)
		sum += (tmp[i] - '0') * pow(10,len_t-i-1);

	return sum * f / pow(10,d_n);
}

int main() {
	int Case;
	cin >> Case;
	getchar();

	for (int i = 1; i <= Case; i++) {
		memset(str,0,sizeof(str));
		double P = 0;
		double U = 0;
		double I = 0;
		gets(str);
		int len = strlen(str);

		for (int j = 0; j < len-1; j++) {
			if (str[j+1] == '=') {
				if (str[j] == 'P')
					P = get_value(str,j+2);
				else if (str[j] == 'U')
					U = get_value(str,j+2);
				else if (str[j] == 'I')
					I = get_value(str,j+2);
			}
		}
		
		printf("Problem #%d\n",i);
		//cout << P << endl;
		//cout << U << endl;
		//cout << I << endl;
		if (P && U)
			printf("I=%.2lfA\n",P/U);
		else if (U && I)
			printf("P=%.2lfW\n",U*I);
		else if (I && P)
			printf("U=%.2lfV\n",P/I);
		cout << endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值