C Looooops(欧几里德+poj2115)

H - C Looooops
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Appoint description:  

Description

A Compiler Mystery: We are given a C-language style for loop of type  
for (variable = A; variable != B; variable += C)

 statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2   k) modulo 2   k.  

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2   k) are the parameters of the loop.  

The input is finished by a line containing four zeros.  

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate.  

Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766
FOREVER

 

 

 

 

.

 

.

 

.

 

题意:for(i=A;i!=B;i+=C){i%(2^k)};问你循环执行几次?

 

思路:先假设等式成立:(A+x*C)%(2^k)=B

 

          变形(2^k)*y+B=A+C*x        ==>        C*x+(-(2^k)*y)=B-A;

 

                                                                         ax+by=c

                      所以现在你知道怎么做了吧。哈哈!

 

转载请注明出处:http://www.cnblogs.com/yuyixingkong/

 

题目链接:http://poj.org/problem?id=2115

 

#include<stdio.h>
#define LL unsigned long long
void exgcd(LL a,LL b,LL& d,LL& x,LL& y)
{
    if(!b){d=a;x=1;y=0;}
    else
    {
        exgcd(b,a%b,d,y,x);
        y-=x*(a/b);
    }
}
int main()
{
    LL A,B,C,k;
    while(scanf("%llu%llu%llu%llu",&A,&B,&C,&k),(A+B+C+k))
    {
        LL a,b,c,d,x,y,dm;
        c=B-A;
        if(c==0){printf("0\n");continue;}
        a=C;
        b=(LL)1<<k;
        exgcd(a,b,d,x,y);
        if(c%d){ printf("FOREVER\n");continue;}
        dm=b/d;
        x=(((x*c/d)%dm)+dm)%dm;

        printf("%llu\n",x);
    }
    return 0;
}


 

 

 

 

 

 

  • 4
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 5
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 5
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值