HDU 4493



Tutor

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 2334    Accepted Submission(s): 638


Problem Description
Lilin was a student of Tonghua Normal University. She is studying at University of Chicago now. Besides studying, she worked as a tutor teaching Chinese to Americans. So, she can earn some money per month. At the end of the year, Lilin wants to know his average monthly money to decide whether continue or not. But she is not good at calculation, so she ask for your help. Please write a program to help Lilin to calculate the average money her earned per month.
 

Input
The first line contain one integer T, means the total number of cases.
Every case will be twelve lines. Each line will contain the money she earned per month. Each number will be positive and displayed to the penny. No dollar sign will be included.
 

Output
The output will be a single number, the average of money she earned for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign without tail zero. There will be no other spaces or characters in the output.
 

Sample Input
  
  
2 100.00 489.12 12454.12 1234.10 823.05 109.20 5.27 1542.25 839.18 83.99 1295.01 1.75 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00 100.00
 

Sample Output
  
  
$1581.42 $100
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   5061  5060  5059  5058  5057 

题意:求12个数的平均数。

坑点:结果精确到便士,也就是小数点后2位,不输出后缀0。

#include<stdio.h>
#include<string.h>

int main()
{
   int T,i,len;
   char str[100];
   double a,s;
   scanf("%d",&T);
   while(T--)
   {
      s=0;
      for(i=0;i<12;i++)
      {
         scanf("%lf",&a);
         s+=a;
      }
      s/=12;
      sprintf(str,"%.2lf",s);//函数功能:把格式化的数据写入某个字符串
      len=strlen(str);
      len--;
      while(str[len]=='0')
      len--;
      if(str[len]=='.')
      len--;
      str[len+1]='\0';//或者是赋为0;
      printf("$%s\n",str);
   }
   return 0;
}



四舍五入

#include<stdio.h>

int main()
{
   int T,i,b;
   double a,s;
   scanf("%d",&T);
   while(T--)
   {
      s=0;
      for(i=0;i<12;i++)
      {
         scanf("%lf",&a);
         s+=a;
      }
      s/=12;
      b=(s+0.005)*100;//四舍五入;
      printf("$");
      if(b%100==0)
      printf("%.0lf\n",s);
      else if(b%10==0)
      printf("%.1lf\n",s);
      else
      printf("%.2lf\n",s);
   }
   return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值